Unable to access billing portal

Hello,

I recently updated my Invoice Ninja install to the latest version as of 11/25/2017 via Softalicious. When I try logging into the system using my admin credentials I keep getting a message that says “Whoops something went wrong”

Is there any error log I can access to view what’s going wrong with the server?

The error log is storage/logs/laravel-error.log

Hello, thank you for the prompt reply. Below is the text of the error message that I’m receiving.

[2017-11-25 20:26:10] production.ERROR: Illuminate\Database\QueryException [42S22] : /home/charles/public_html/billing/vendor/laravel/framework/src/Illuminate/Database/Connection.php [Line 729] => SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘invoices.is_public’ in ‘where clause’ (SQL: select COUNT(DISTINCT CASE WHEN invoices.id IS NOT NULL THEN clients.id ELSE null END) billed_clients, SUM(CASE WHEN invoices.invoice_status_id >= 2 THEN 1 ELSE 0 END) invoices_sent, COUNT(DISTINCT clients.id) active_clients from accounts left join clients on accounts.id = clients.account_id left join invoices on clients.id = invoices.client_id where accounts.id = 1 and clients.is_deleted = 0 and invoices.is_deleted = 0 and invoices.is_recurring = 0 and invoices.is_public = 1 and invoices.invoice_type_id = 1 group by accounts.id limit 1) {“context”:“PHP”,“user_id”:1,“account_id”:1,“user_name”:“Charles Costa”,“method”:“GET”,“url”:“http://domain/billing/public/dashboard",“previous”:“http://domain/billing/public”,“user_agent”:"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36”,“ip”:“47.21.68.155”,“count”:7,“is_console”:“no”,“is_api”:“no”,“db_server”:“mysql”} []

Try loading /public/update and checking for any errors

Actually on your install it would be /billing/public/update

Thanks! Now it’s working.

Great to hear, thanks for letting us know!