Trying to create a task with Zapier

Hi, I’m getting an error when trying to create a task with zapier. My setup is simply taking a time-entry from Clockify and adding it to InvoiceNinja as a task.

Zapier is not very helpful when/how the error occurred so I hope this is enough info

@luan

It would be helpful to know what the request is looking like, a task in InvoiceNinja only needs a description to start. If you also need to push time fields you can use the timelog property.

It accepts an array of unixtime stamps which define the start/finish times of the task, ie.

[[123,456],[789,0123]];

For a task that is running the last property of the array should be a zero, ie:

[[123,0]]

Ok, thanks for the reply @david . I tried to create a task with only the description and it worked. So, looking at the request, I think there are a few things that I don’t know how I could address automatically:
I have the same client’s name in both platforms but invoiceninja only accepts client id; It’s the same for projects; I don’t see an option to add rate in zapier (I can get rate from clockify) but in the test it shows up as a response; Time stamps worked.

So I guess the problem lies on client and project, instead of Ids, they should be names and as for projects, create a new one if it doesn’t exist (maybe client as well? Idk)

It looks like the task rate isn’t currently available in Zapier, we’ll add it with the next release of the integration.

Another thing: I have an option to add both hours and minutes durations, but the response is just ‘duration’ and it is always ‘0’ so I guess it’s not working?

The duration field is deprecated, only the time_log field matters