Trouble with the Invoice Ninja android app.

I have been using the Invoice Ninja android app. Now all of the sudden I get “Invalid Token”. I double checked my API secret. Still won’t connect. Any Ideas?

Have you tried logging out and then back in?

Note: the invalid token message is referring to the token on Settings > API Tokens, not the API secret.

I did. I also tried adding a new API token. I tried uninstalling the phone APP, clearing the phone cache, reinstalling.
I did add a new pfsense firewall to the mix. Could that be blocking something? If so what should I look for?

I don’t think the firewall would impact it but you may want to see if temporarily disabling it helps.

So I just updated to version 4.5.3… That got rid of the API error; However now when I try to log in, it just says “Something went wrong”. I have no idea what to do with that.

I can see the issue, it is related to an update in 4.5.3

I will be pushing up a new version of the Android app shortly which will resolve this.

Thanks! I’ll keep an eye out for it.