The v5 stable release is now available

storage/logs Have only laravel.log which shows "production.INFO: db fails " but did not come to DB config yet

@david, @ben any ideas?


Are you following one of the official guides? It sounds like the VHost url isn’t configured correctly.

checked - /invoice-ninja owned by www-data /storage set to 755

v-host goes to /invoice-ninja/public

Free Open-Source Invoicing, Expenses & Time-Tracking | Invoice Ninja - from here.
Tried on another ubuntu machine php:
php -v
PHP 8.0.3 (cli) (built: Mar 5 2021 07:53:56) ( NTS )
Copyright © The PHP Group
Zend Engine v4.0.3, Copyright © Zend Technologies
with Zend OPcache v8.0.3, Copyright ©, by Zend Technologies

But instead of setup it shows code "<?php

// your application code


  • Laravel - A PHP Framework For Web Artisans
  • @package Laravel
  • @author Taylor Otwell

define(‘LARAVEL_START’, microtime(true));

That means you haven’t configured mod_php

Following official guide?

configuring mod_php wouldn’t be in the official guide, but here is a link to the installation guides we have

this is the link I’ve been following to…nothing about mod_php

To run any PHP site, you need to configure a PHP handler whether that be PHP-FPM for nginx or mod_php for apache.

You’ll need to configure mod_php for your platform.

The other machine’s virt-host is set correctlychange of user and permissions but "Oops, looks like something isn’t correct! "straight at the first page?

And on self-hosted PDF also acts strange - one time everything is ok, then ERROR 500 on chrome and edge

There should be more information in storage/logs/laravel.log which explains the error.

Thanks a lot for this amazing work, I got it working yesterday on a self-hosted Ubuntu 20.04. It took a bit of fine tuning, but it’s great.


finally, got the v5 to work. the link on your page for 5.1.14 has bugs after you install, smtp settings have localhost user error. but today, i used the code from v5.1.26 and i am able to set it up. some times, there is a time error while you try to save a changes to a settings…also, login gives an xml error if you have /#/ at the end of your url. once you delete that, you can login.

so far I AM PLEASED!!!..still exploring.

I was asking for a TENANT kid of user account…and its already there…COMPANY = TENANT so, each company added can see only the invoice, clients, users, vendors etc that they add…which is all i wanted. only MAIN admin can see all TENANTS aka companies and what they have created, etc.

now, is it possible to enforce a SECRETE for every user login via the app and via web url. I am waiting for 2-STEP-VERIFICATION to improve security…having to enter that long API secrete code into the app sign in is a pain. unless you email the code to yourself, open email on the same phone then copy the secrete into the filed.

if you add a 2-STEP verification, make it easy for main admin to reset / remove it in the backend should a use loose their device / phone and buys a new one and needs to re-authenticate at sign in.

is it possible to manually add a SESSION TIME OUT figure?..the lowest time on the preset is 8 hours. for me, max I want is 15 minutes for session to time out, log out the user for inactive.

and how many users can login at once into 1 company?..any where i can set an allowed number of simultaneous sessions / login? …so the same user account cannot login twice from 2 different IP or same IP address. or maybe it should not matter the way it is right now

am going to buy a license to support your work. THANK YOU AGAIN #TEAMINVOICENINJA

Glad to hear it’s working! If you can post details for the errors you’re seeing we can try to help.

We’re currently working on implementing 2FA, it should be available soon. We can add shorter session timeout options.

Feel free to create an issue to request supporting max simultaneous sessions.

XMLHttpRequest error is the error message i get when i out and then try to sign in again…is this normal?

If you’re still having a problem please create a new post and we’ll help you there.

I couldn’t find an update in Softaculous but I tried to fresh install on another domain to test v5. Here are few questions:

  1. How can I add 2Checkout as a payment gateway? This is what I’ve already configured in the previous version 4.
  2. How can I import all of my data from old domain to the new one?
  3. At the bottom left corner it’s showing me error that says “The cron job needs to be done”. I’ve already tried refreshing the data under Device Settings, it’s still there.

Thank you!