The v5 stable release is now available

this is the link I’ve been following to…nothing about mod_php

To run any PHP site, you need to configure a PHP handler whether that be PHP-FPM for nginx or mod_php for apache.

You’ll need to configure mod_php for your platform.

The other machine’s virt-host is set correctlychange of user and permissions but "Oops, looks like something isn’t correct! "straight at the first page?

And on self-hosted PDF also acts strange - one time everything is ok, then ERROR 500 on chrome and edge

There should be more information in storage/logs/laravel.log which explains the error.

Thanks a lot for this amazing work, I got it working yesterday on a self-hosted Ubuntu 20.04. It took a bit of fine tuning, but it’s great.

3 Likes

finally, got the v5 to work. the link on your page for 5.1.14 has bugs after you install, smtp settings have localhost user error. but today, i used the code from v5.1.26 and i am able to set it up. some times, there is a time error while you try to save a changes to a settings…also, login gives an xml error if you have /#/ at the end of your url. once you delete that, you can login.

so far I AM PLEASED!!!..still exploring.

I was asking for a TENANT kid of user account…and its already there…COMPANY = TENANT so, each company added can see only the invoice, clients, users, vendors etc that they add…which is all i wanted. only MAIN admin can see all TENANTS aka companies and what they have created, etc.

now, is it possible to enforce a SECRETE for every user login via the app and via web url. I am waiting for 2-STEP-VERIFICATION to improve security…having to enter that long API secrete code into the app sign in is a pain. unless you email the code to yourself, open email on the same phone then copy the secrete into the filed.

if you add a 2-STEP verification, make it easy for main admin to reset / remove it in the backend should a use loose their device / phone and buys a new one and needs to re-authenticate at sign in.

is it possible to manually add a SESSION TIME OUT figure?..the lowest time on the preset is 8 hours. for me, max I want is 15 minutes for session to time out, log out the user for inactive.

and how many users can login at once into 1 company?..any where i can set an allowed number of simultaneous sessions / login? …so the same user account cannot login twice from 2 different IP or same IP address. or maybe it should not matter the way it is right now

am going to buy a license to support your work. THANK YOU AGAIN #TEAMINVOICENINJA

Glad to hear it’s working! If you can post details for the errors you’re seeing we can try to help.

We’re currently working on implementing 2FA, it should be available soon. We can add shorter session timeout options.

Feel free to create an issue to request supporting max simultaneous sessions.

XMLHttpRequest error is the error message i get when i out and then try to sign in again…is this normal?

If you’re still having a problem please create a new post and we’ll help you there.

I couldn’t find an update in Softaculous but I tried to fresh install on another domain to test v5. Here are few questions:

  1. How can I add 2Checkout as a payment gateway? This is what I’ve already configured in the previous version 4.
  2. How can I import all of my data from old domain to the new one?
  3. At the bottom left corner it’s showing me error that says “The cron job needs to be done”. I’ve already tried refreshing the data under Device Settings, it’s still there.

Thank you!

Hi,

  1. They aren’t yet supported but we’ll be adding more gateways in the coming months.
  2. To upgrade from v4 you need to install v5 as a separate app and then use the migration tool in the latest version of v4 on Settings > Account Management.
  3. There’s more info here: Free Open-Source Invoicing, Expenses & Time-Tracking | Invoice Ninja

Oh! In that case I will wait then until it’s totally stable and have all the features that v4 has.

Installed v5 today via Softaculous and I’m still getting plenty bugs. Hopefullt I’m the one missing steps here.

If you’re having problems with the app please create a new post with details about the errors

1 Like

@hillel, I have a question. I gone to the hyperlink that you provided, your version is 5.1.62 and the one that we installed yesterday night twice was 5.1.65 - c48 — should I been using your hyperlink since we are having issues with ours? I have another posting for help regarding uploading files, which you added a post.

Let me know…
thanks,
Mike

I have Apache and Nginx on my Vultr server at Cloudways.

From my understanding, I should be creating a new install location for Version 5 (since my old software is version 4+). However, I’m not clear that I can follow these directions properly for my environment. Free Open-Source Invoicing, Expenses & Time-Tracking | Invoice Ninja

Which directions should I be using exactly?

I’v asked cloudways if I can run the ubuntu sudo commands and they have said I cannot. Even though, my apache runs on ubuntu machine. So I don’t know my alternative ways to install this software.

Is there no way to just manually install the files, create a database and run the setup file or create a .env file?

Hi,

In general we recommend this guide:

EDIT! CAME UP WITH A GREAT EASY SOLUTION FOR INSTALL ON ALMOST ANY SERVER. WILL HAVE UPDATED BLOG POST SOON.

So, cloudways says I can’t run sudo commands on ubuntu. So should I just assume I can’t use invoice ninja v5 because there is no way for me to install it? If thats the case, I guess I’m forced to try and look for something else for my invoicing. :frowning:

I’m not even on a shared server. I pay for my own server. And even then, I can’t even follow these shared server instructions because he’s having the same troubles as me.

Sorry for the delayed response but happy to hear you found a solution!