Tasks issues and suggested improvements (v 5.2.7)

Hello I have a few points regarding tasks in general:,

  1. I noticed that there is a checkbox (for multi selection) in the Tasks module in Kanban view, but clicking it does nothing:

It seems one has to be in list view or table view for the multi selection tool to work. Shouldn’t the icon be hidden in Kanban view, then?

  1. As for the multi selection tool itself, is there a way to batch select/edit tasks (to say, change their status)? For now when turned on, the multi select only allows manually adding tasks one by one to the selection - I can’t find a way to batch select them, like the usual shift+click, besides the “select all” feature. And when multiple tasks are manually selected, I couldn’t find a way to batch edit them either, I could only batch invoice, batch archive or batch delete.

  2. I also noticed that some tasks have broken statuses: for instance, this task it neither flagged as Invoiced, Logged or Running so it shows up with any combination of those filters, including none:

I don’t recall doing anything special to this task; it’s currently active (not archived or deleted). Any ideas on how to fix it? I guess I could edit the database, but I’d rather not if there is another solution. BTW, this “broken” task gets filtered properly in Kanban view, but not in table view or grid view. That might be because Kanban cannot sort “Invoiced” taks for some reason (only Logged and Running are available). In any case, something appears a little buggy here.

  1. I reported this in another thread a few weeks ago ( V5 Android app | Tasks and touch input issue - Discourse (invoiceninja.com)) but for the sake of regouping issues regarding tasks in this thread, here it goes:

When using the v5 Android app, dealing with tasks in Kanban view is a bit cumbersome, as merely touching a task fires up the text editing of its description, so there is no easy way to just start/stop a task without first having to go through and dismiss the editing.

On the browser version, this is not a problem, as a mouse cursor can hover over the task and then the submenu to view/start/pause pops up; but since there is no way to do a mouse over with touch input, I think that the feature of “editing text as soon as selected” is a bit broken at the moment.

That’s all for now, thanks in advance!


Thanks for the feedback!

  1. Noted, we’ll look into disabling the button in the Kanban view.

  2. This isn’t supported, please create an issue for each feature request here: Issues · invoiceninja/invoiceninja · GitHub.

  3. I would expect all tasks to show when no filters are selected. The Kanban board is designed to handle un-invoiced tasks, invoiced tasks are hidden.

  4. This has been implemented.

Hi @hillel,

Great, thanks!

Understood, I’ll do that soon along with some other requests I had pending.

OK, thanks for explaining why Kanban didn’t show the invoiced filter; I don’t personally invoice tasks, so that’s a moot point in my case, but still, I’m just double checking everything works fine.

As for all tasks showing up with no filter, that used to be the behaviour I had too; I guess today’s update did something wonky with the cache so I ran php artisan optimize and now this part works fine.

However, I still have a problem with filters being a bit broken for some tasks. It seems like different combinations of filters will have different, unexpected results. For instance:

Active + Running = the following task

Notice the time: it hasn’t even started, but it’s flagged as running.

Active + Invoiced = the same task shows up (I never invoiced it… or maybe I accidentally hit “invoice task” at some point by mistake and cancelled the invoice?):

Active + Logged shows that same task too:

But now if I untick “Active” (with no other filter on) and I try either “Invoiced” or “Running”, now the task won’t shop up, even though it’s actually active.

Even weirder, if I activate “Invoiced” and then “Active”, the invoice does not show up, but if I tick the filters in the reverse order (Active → Invoiced), then it shows up.

It’s a bit hard to describe, I hope it makes sense. Basically, the filters do not behave logically for some tasks. I get weird/impossible results for the following combinations (and in that filter activation order):

  1. Active → Invoiced (Invoiced → Active gives no results)
  2. Active → Running (Running → Active gives no results)
  3. “No filter” → Invoiced (Just ticking “Invoiced” shows that task, but it’s archived and doesn’t show up with Archived → Invoiced)
  4. Archived → Running (Running → Archived gives no result)

I can’t see that on my Android app; I tried updating it but the last version on Google Play Store is from May 22nd (v5.0.49). I tried reinstalling the app just to make sure, but I still can’t see any changes to the mobile interface in Kanban mode: when I tap tasks with my finder it automatically enters text edit mode; I then have to tap elsewhere on the screen to close the edit box and then the text buttons appear under the kanban card.

Am I missing something?


There could be a problem with the task filters, I’ll try to reproduce the problem.

We just released the new mobile app yesterday, it may take time to process in the store.

1 Like