Stop printing invoices to PDF on page load and invoice save

Maybe I’m completely overlooking something here but when I load an invoice or save an invoice it is automatically printing to PDF which is really annoying. How do I turn that off? This is happening in FF. I believe Chrome does the same thing.

Can you confirm if you’re seeing the problem in Chrome as well, it’s a known issue with Firefox.

You can force the app to use a JavaScript PDF renderer by loading /force_inline_pdf

You’re right. Doesn’t do it in Chrome. How do I fix FF? I"m unclear from your answer.

I could fix this by changing the pdf settings in Options > Applications to show pages in FF.

Don’t have an English FF here, but if you go to Options > Applications and do a search for pdf it will hopefully be clear what needs to be done.

Thanks for sharing your solution!

I am having a similar issue using Chrome on Android. Whenever I login and go to view one of my invoices, it keeps auto downloading the invoice over and over again. Anyone have a solution for this?

You can make the app to use a JavaScript based PDF renderer by loading /force_inline_pdf

Where do I do this exactly?

BTW, I didn’t intend to hijack someone else’s thread, but I don’t see an +new topic button anywhere. Is there one to be found one here? :slight_smile:

In your browser. ie, load (or /public/force_inline_pdf)

There should be an option to create a new post at the bottom of this page: