Sorting on customer number not working on V5

Migrated to V5 but get some strange issues with customer numbers. I have four companies in my Pro plan, one is ok. That company I can sort on customer number. I got one company where the customer numbers are a bit weird, like e.g. 3.0624000000368e16. There sorting doesn’t work if I want the latest customer. It is sorted like 3.0624000000368e16, 4, 3, 2, 1.

And another company where in customer panel I get 99, 98, 97, but there are more than 99 customer. So I can’t get to view the latest customers easily.

This problem wasn’t there on V4.


Not sure about the first, do you have any custom patterns set on Settings > Generated Numbers?

@david any thoughts?

I’ll look into the second issue with sorting.

I checked with the three companies and they have the same settings:
distance 1 and generate number as stored.

I did a test on the sorting.

I guess it has to do with how the customer numbers get migrated. In the company where the sort fails the numbers are with and without preceding zero’s. So I have 00, 01, 02…09, but then it goes to 10, 11 … When sorting for higest number I get 99 on top while there are more than 99 customers…

Thanks for the details. I think this may be from lowering the zero padding (01 vs 0001). If you increase the padding it should correct it but we’ll also look into sorting correctly in this case.

Where can I increase the padding?

The option is on Settings > Generated Numbers

Ah Number Distance. I changed it but doesn’t help with sorting. So yes, pleas look into sorting correctly.

That setting will only affect new invoices, you would need to manually correct the current invoices to add the zero padding.

That is a lot of work if there are a couple of hundred customers… Is there not a better solution?

You can wait for the next release, we’ll try to correct the sorting in the app.

Thanks.Sorting is sorted out.

Glad to hear it, thanks for the update!