[SOLVED] Trying to Migrate to Docker v5, no such file

I am attempting to migrate from 4.5.33 to V5 with docker.

I have a fresh install of Docker, with the username and password the same as in V4.

I have run sudo chown -R 1500:1500 ./INVOICENINJA/ to ensure the permissions for storage and app should be correct.

The migration lets me go all the way to companies page, but when I click continue, I get an error page.

Here’s a snippet:

ZipArchive::close(): Failure to create temporary file: No such file or directory

in StepsController.php line 262

at HandleExceptions->handleError(2, ‘ZipArchive::close(): Failure to create temporary file: No such file or directory’, '/var/www/html/invoiceninja/app/Http/Controllers/Migration/StepsController.php

Is there a permission (possibly in the app docker) that needs to be tweaked?

@david, @ben any ideas?

@cwesterfield

The issue will be in your V4 docker container instance, the app is not able to write to the storage directory.

The v4 is a regular debian install. Let me check and see whats going on there.

Permissions looked fine. I got it to continue on by manually creating the migration folder.

mkdir storage/migrations
chown -R www-data:www-data storage/

After that it worked!

1 Like