SMTP selft certificate

I have my own mail server that has been working fine for years, but my server locally is self-certified.
I can successfully send emails from the computer that has invoiceninja installed using any of these options

openssl s_client -starttls smtp -ign_eof -crlf -connect

telnet 25

openssl s_client -showcerts -connect -servername

openssl s_client -showcerts -connect -servername

but invoiceninja shows …

Screenshot 2022-08-07 200048

Let’s Encrypt is not a option for me because the smtp is close from the wan side
How can I get invoiceninja to accept a self-certificate?

which operating system are you on, we are seeing issues with Ubuntu 22.04 currently

Im using Debian 11 bullseye

I had the same problem yesterday,
I solved it by setting encryption to null and port to 25 in .env file till I find a solution.

That was one of the first things I tried, locally I don’t need to encrypt but I need to authenticate

I also modify the file ./config/mail.php

Screenshot 2022-08-08 171502

But I was unlucky

The truth is that I don’t care if I don’t use encryption or if it’s ssl or tls I just need it to work. but I don’t know how to do it with a self-certificate