SMTP bug reappeared? Wrong "from" address?

I have my SMTP settings setup so that I have a different “sent from” address ( than I do the login for the SMTP server (

Invoice Ninja is currently sending all of my invoices using the SMTP login address instead of the “send from” address that I set up in the beginning. The same issue as described in v5: A few questions (self-hosted) · Issue #4407 · invoiceninja/invoiceninja · GitHub

I am using version v5.1.62-C47, self-hosted on an AWS Lightsail instance using Nginx. Everything technically works fine, however I don’t want all invoices sent by the company to come from my personal work email.

Thank you for taking the time to read my post and if you have any thoughts, I would love to hear them!


@david any thoughts on this?

Are you sure it isn’t the replyTo address that is being set to the other address?

Thank you for responding!

I am attaching a redacted screenshot of my .env file and my email settings in the app to show my current config.

Again, if I messed up the config, please let me know. Thank you so much!

Can you take a screen shot of the email when received, i’m interested to see the FROM and REPLYTO fields

I have attached a redacted screenshot of the raw email from Yahoo. (I send my test invoices to my personal email address.)

Hopefully this helps!