Signature and terms of service check for invoice and quotes not working?


My name is Nick van Kesteren. I’ve installed Invoice Ninja via Softaculous. Everything went fine. When I setup everything and send a test quote and invoice I saw a few things…

When enabling the checkbox for having to read the terms of service I get an error when I try to accept it as customer.

When enabling that same checkbox for quotes it doens’t give me anything and sets the quote directly to accepted. Also when requiring a signature for a quote it goes straight to accepted. I’ve tested it together and separately from each other.

Can someone help me? I really need such a check to be able to send quotes and invoices to customers.

Thanks in advance!

My sincerely,

Nick van Kesteren

What error are you seeing?

The error I’m getting is: Something went wrong. Please renew the page and try again.

I get that error with invoices, when having one of those options enabled, or both at the same time.

And with quotes I don’t get any error, or accept or sign screen, it directly sets the quote to accepted.

Are there any related errors in storage/logs/laravel-error.log

No, but there are two things there:

  • [2018-01-08 20:52:06] production.ERROR: Swift_RfcComplianceException [0] : /home/congreats/domains/ [Line 345] => Address in mailbox given [] does not comply with RFC 2822, 3.6.2.

  • [2018-01-08 20:55:46] production.ERROR: Swift_TransportException [0] : /home/congreats/domains/ [Line 404] => Connection to my.mail.server:123 Timed Out

But sendings emails worked after that time.

If you want to email a ‘view as recipient’ link to I can try to debug it.

I’ve sent an email. Thanks in advance!

Thanks! I’m seeing a 403 error, are there any errors in your web server error logs?

I can’t find any, but maybe if you can enter the code you can figure it out. I will send FTP data to that email above.

Please don’t, our policy is not to log in to user’s servers.

Too bad.

I hope that this problem can be solved.

I’d suggest searching for the error log, the 403 should be tracked.

I’ve found something.

[Tue Jan 09 09:12:39.001626 2018] [access_compat:error] [pid 16327:tid 139746977945344] [client 2a02:a212:2880:2b00:74b3:98b1:80e3:2162:45330] AH01797: client denied by server configuration: /home/congreats/domains/, referer:
[Tue Jan 09 09:44:28.268375 2018] [access_compat:error] [pid 29199:tid 139746843662080] [client] AH01797: client denied by server configuration: /home/congreats/domains/, referer:

Does this help?

I’d suggest following up with your web host, something is blocking the request.

I’m going to do that. I will keep you posted. I will also ask if I have any more questions. Thanks!

I’ve found something in the path the script wants to go to… it says ‘’ instead of ‘’.


How can I change that?

I’ve updated your posts to remove your domain

Remove my domain? is not my domain, is. But for some reason the script wants to go to

You posted links in your comments to your server, that isn’t such a good idea as crawlers may gather them.

I’ve tried to remove them for you.

Oh now I see. I’m sorry, not a native English speaker :slight_smile: