Setup - Email giving error and not proceeding to the next step

Setup - Email giving error and not proceeding to the next step but receiving email test.

SQLSTATE[HY000] [1045] Access denied for user ‘ninja’@‘localhost’ (using password: YES) (SQL: insert into jobs (queue, attempts, reserved_at, available_at, created_at, payload) values (default, 0, ?, 1614619519, 1614619519, … Your system won’t let me add more text with links.

Link to video —>

Hey there, thanks for reporting this.

@david what do you think? You can’t proceed to email configuration unless DB connection is passing. What could be wrong here?

DB Credentials are wrong

I got the same issue a couple of days ago by reinstalling IN 5. The problem was that the installer is not considering the DB values fileld on the screen during the prechecks. So i had to edit manually the .env with proper mail parameters and it solved the issue.

And still some settings are not migrated from V4 to V5, do you have some updates about Info after upgrading to 5.1.1-C41 from GUI ?



I’ve added those items to my backlog, i’ll get this in for the next release.

Great, thank you @david !

I can proceed to email. I fill out all email info. I get the email test sent to my email box but I get a error and it will not go on to the next step. Link to video—>

Just set as mail “log” and edit .env mail settings afterwards.

Yeah, looks like there’s a bug in installer. Like David said, it should be fixed by next release.

For now, workaround suggested by Ubi should work just fine. Use log, then edit your .env & run php artisan optimize :+1:

I am having the same problem with [Release v5.1.14-release] as I did with [Release v5.1.13-release]
I had my host look over my VPS Server and they could not find anything wrong. I will try to do what Ubi suggested. I looked in my database an no tables found in database.

1 Like