Server Error 500 after applying payment - payment missing invoice=paid,archived,payment pending

Upgraded from 5.3.4x to 5.3.79-c78 today. PHP ver is 7.4.3.
I had problems and followed the instructions to update “compose” ver 2. Got it working and seemed to be ok. Was able to create tasks today but haven’t done anything else. I just attempted to enter payment and got server error 500 from my phone (and a test from computer after that resulted in same) but:

  • the payments have gone missing ie. they don’t show in the payment section anywhere
  • the invoice has the “payment pending”
  • the invoice gets archived and marked as paid (despite “payment pending” and missing payment entry)
  • No problems showing in laravel log. (after the update problems earlier in the day)

Any help would be very much appreciated.
Thanks very much.


Are there any details about the 500 in storage/logs?

Nothing in laravel.log. That’s the only log in the folder. The laravel.log is being written to. There is a currency update and autobill that are mentioned in the log after the errors that occurred during the upgrade and after my first message.

@david do you have any thoughts?


Not sure on this, if the laravel.log file is there and being written to the 500 errors should be dumped into that file.

I would try running

php artisan migrate

to see if any migrations haven’t run as this could cause issues like this.

So we’re clear - I updated from ver 4 to 5 months ago. Have done several v5 updates. I’m getting a warning: "APPLICATION IN PRODUCTION! Do you really want to run this command y/n

This is safe to do?

So I think I may have done those 2 payments from my phone and they screwed up as described (android app). I was fooling around with the Linux Desktop App (snap) and may have done the 2nd payment on there. I honestly can’t remember. I don’t use the linux snap app in general (pdf issue I haven’t looked into) – just thought I would give it a try.

Just now, I tried again from my browser and it worked this time BUT … there was a gap in the payment numbers. ex.1076 to 1079
I managed to get it sorted by viewing the invoices with the “archived / paid / payment-pending” status and assigned numbers 1077 and 1078 to get everything back in working order. The payments now show up and the invoices are now just paid and archived (no “payment pending”). So crisis averted. Maybe you want to look at the android app and or snap app though just in case there is a problem there vs how the browser works? I’ll stick with the browser going forward.

For your reference, on the phone - while making the payment, it let me pick the client, pick the invoice with the matching amount. All normal. It kicked the 500 error when I clicked save. So it was reading the database ok, it just seems to have had a write issue in that section. In the minutes previous to this, I did a task and it logged no problem (this is what I use most from the phone anyway) so no write problem there.


Ok thanks for the update. If error is reproducible let us know, or if you are able to get the log with the 500 error please advise and we can look into it.