Self Host | Install | .htaccess Issue

I’m currently test running the self-hosted Invoice Ninja package. Issue is I installed on MAMP (Mac OSX) and I discovered that each time I try to access the application folder, it rather displays the content of the folder itself and I can only access the application on clicking the ‘public’ folder.

The installed path is this http:localhost/ninja/ this displays all the subfolders therein until I click on the public folder before it can be accessed. How can I solve this issue?

Also, I want the login interface that allows new company to be added or existing user login, how can I enable that view instead of the single login interface?

To remove ‘public’ from the URL you’ll want to map your webserver root directly to it by setting the DocumentRoot to /path/to/ninja/public.

There’s more info here:

If you load the login page with the following URL the new company button is shown: /login?new_company=true

Hi Coren,
Thank you for the prompt response.

Unfortunately, I’m using MAMP stack for LAMP and so cannot set the document root as pointed out here but anyway since its just for test purpose, it will suffice.

Issues I noticed based on my proposed scenario for use which is to enable independent users create their own respective company accounts to manage their own clients all independent of the other. I noticed however that currently to create a company meant that the application setup was carried out by the same person going to setup additional companies.

I would have preferred or let me use suggest that there is a central Super Admin that manages the application setup and can either create other users’ companies as the need arises and also have an oversight management over them all.

In addition to this, users can come on the application and create their respective companies without having to be the installer of the application.

They shouldn’t have to log in to the application initially before doing this but rather the process lead them to create their own login.

Tried uploading a screen capture now but not going through. The capture shows a bug I guess whereby when one creates more than 3 companies, on attempting to create a 4th one, the ‘Add Company’ button (green button) redirects wrongly to a different URL http://localhost/login?new_company=true instead of http://localhost/ninja2/public/manage_companies.

I must commend you for a great job so far and look forward implementing your application and also contributing in terms of ideas to move it on further.

Awaiting your kindest response.


We’re trying to make the application as self-manageable as possible to ensure users can do things themselves (resetting passwords, unlocking accounts, deleting accounts, etc).

I’ll see if I can replicate the issue when adding more than 3 companies.