Recurring Invoice Set Pending

Hello.
I have the cron setup, but am wondering if there is a good method to validate that it is running every 10 min as planned. I setup a recurring invoice and hit start, and it still says pending. This is a test, so I set it up as recurring daily, which did not happen.

Any good method to verify? I’m self hosting on shared hosting, so I did set it up through cPanel. My host believes it is setup correctly, but how can I verify?

Hi,

If the cron isn’t running you should see an error in the app.

Note: in v5 we recommend configuring the cron to run once a minute.

I’m not seeing an error, so is there something else I can check?

@david what’s the best way to check that the cron is running?

Just updated to run every minute, but still not convinced its running correctly.

The cron is set as follows:

cd /home4/bbcomputing/public_html/billing && /opt/cpanel/ea-php74/root/usr/bin/php -d register_argc_argv=On artisan schedule:run >> /dev/null 2>&1

@BBComputing

If you inspected the accounts table in the database, the is_scheduler_running column should be set to 1

we have a background cron task which sets this column to 1, this is the only guaranteed way to know if the cron is working.

That is in fact set to “1”… however recurring invoice still says pending even though it should be recurring daily, and has been started.
Additionally, I changed cron to run every minute and this then threw a segmentation fault and my host changed it back to every 10 min. Is that common?

Any other ideas of what this issue could be? Just tested again, still set to pending (on a daily recurring invoice).

Would really love to start using invoice ninja, but this is holding me back.

Team - Any updates here?

@BBComputing

It sounds like the crons are not running for you on your host.

One option is to try using the webcron that can bypass this,

https://invoiceninja.github.io/docs/self-host-troubleshooting/#webcron-configuration

@david I believe we confirmed that the cron is working (via the db value showing ‘1’), and my webhost confirmed its working as well though. Seems odd, doesn’t it?

@BBComputing

Yes, indeed it sounds odd.

Do you have expanded logging enabled ?

in your .env file

EXPANDED_LOGGING=true

if the scheduler is indeed running correctly, there will be logging outputted into the invoiceninja.log file

Sure, I’ll enable that and do the optimize…
As an FYI I tried setting up the webcron or what not and nothing has changed, the recurring invoice is still set to pending.

Is there someone who might be able to investigate this with me live?
I paid for the whitelabeling in August since I wanted to be on invoice ninja and off of zoho invoice by Jan 1… I’m still not able to move over due to this issue, and just had to pay for another renewal of zoho invoice.

I think invoice ninja is an incredibly powerful and useful system, but without this I can’t make the move.

@david is there anyone who could take a look at this with me? Still experiencing the same issue.

@BBComputing

Not sure on this, do you have command line access at all? It would be helpful to know if running

php artisan send:recur

sends the invoices.

Yes, I should be able to run this. Do I do it from the root directory of invoice ninja?

If so - it says “There are no commands defined in the “send” namespace.”