Quote Approval Returning 500 Error

I am self hosting just installing it on Tuesday on Ubuntu/Apache2. It seem a very robust application with the featurs we are looking for. In testing before we put it into production, I’ve found only one issue that I’m struggling with.

We make a quote then email it to our customer. The customer receives the email, clicks on the link and the quote is presented to him. That all works fine, but when he clicks the approve button he receives the WHOOPS, LOOKS LIKE SOMETHING WENT WRONG message with our server returning a 500 error. I’m including the output from the access log below (minus our url) showing the good access to the quote and the 500 error after clicking the Approve button.

I apologize if I’ve missed something in the Forum of the same or similar issue. Does Ninja have an error log file somewhere that may help me figure out what’s going wrong? Any help you can provide would be appreciated. We are looking forward to using Ninja to make our invoicing easier.

Thanks

Customer accessing the link in the email
70.197.208.32 - - [10/Mar/2016:14:34:54 -0600] “GET /ninja/public/view/Ni5fLS3Q94gmVw5trwOJMHao5LaE7ky2 HTTP/1.1” 200 68613 “-” “Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0”

After customer presses the Accept button
70.197.208.32 - - [10/Mar/2016:14:35:03 -0600] “GET /ninja/public/approve/Ni5fLS3Q94gmVw5trwOJMHao5LaE7ky2 HTTP/1.1” 500 4753 “http://oururl.com/ninja/public/view/Ni5fLS3Q94gmVw5trwOJMHao5LaE7ky2” “Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0”

We just heard a report of this from another user, we’ll include a fix with our next release.

For now you can fix it by changing

$account = Auth::user()->account;

to

$account = $quote->account;

in app/Services/InvoiceService.php

Thank you for the extremely fast (4 minutes) response. Excellent customer service! I’m off to edit the code and retest.