Proc_open() not available...can I still use v4 migration?

Hi! I currently run v4 very successfully via softaculous install on a shared web host that allows everything except for proc_open() - I have been able to confirm the databases have been successfully transformed during v4 revision updates, as per here.

My question is - can I setup a v5 server and use the v4 migration tool to migrate directly to it? Or will I need to use an intermediary step since proc_open() is unavailable on the v4 server? Will that cause me any problems/issues when migrating to v5?


I’m not sure. I don’t think proc_open is required for the migration but you’ll need to try it to confirm it.

Sounds good. Do you think it’ll be an “all or nothing” situation? Where, if it works, I can be confident we “got it all” and there won’t be any gotchas later? :slight_smile:

Thanks for the insight and nudge to try!

I think proc_open is mainly required when updating the app.

That would make sense as to why I haven’t had problems yet since Softaculous is doing my updates on v4.

Just to provide some extra feedback: I’m going Cloudron with v5 - it works VERY well and is a great platform after trying it. Manual install seems like so much maintenance and things that could go wrong, I tried Docker and it worked but not as clean as I would have liked it for future updates (needed to git pull and inspect for changes and couldn’t just throw it into my own compose file and go from there). But Cloudron for the win and no more shared server issues. Thanks!

1 Like