Problem With Artisan Crons

I use v4.2.2 in Self Host and when I run the two crons artisan ninja: send-invoices and artisan ninja: send-reminders there is nothing in output.
Of course it does not send any email and also there is no error in logs.
Does anyone know something about this issue to help me ?

Thank you

There’s no output at all? How are you running the commands?

I have tried both cron and terminal and I have the same result.
Here are the commands
/usr/bin/php -q /home/admin/web/mybill/public_shtml/artisan ninja:send-invoices
/usr/bin/php -q /home/admin/web/mybill/public_shtml/artisan ninja:send-reminders

Here you see when I run them from a console
[root@server1 ~]# /usr/bin/php -q /home/admin/web/mybill/public_shtml/artisan ninja:send-reminders
[root@server1 ~]# /usr/bin/php -q /home/admin/web/mybill/public_shtml/artisan ninja:send-invoices
[root@server1 ~]#

Not sure, maybe try removing the -q flag

I have tried it, but again the same result.

If I remember correctly it was presented after the last update.

Have you checked both the web server error log and storage/logs/laravel-error.log

Yes I have looked at them and the strange thing is that there is no error
Also, if I turn on the debug again, I do not see an error

Maybe try running the command from the invoiceninja project folder

/usr/bin/php artisan ninja:send-invoices

Also, what do you see if you run

/usr/bin/php -v

I do it /usr/bin/php artisan ninja:send-invoices
and nothing …
Also here is my php version
PHP 5.6.33 (cli) (built: Jan 14 2018 08:07:11)
Copyright © 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright © 1998-2016 Zend Technologies

Our app requires PHP 7, it could explain the problem

Bingo !!!

/usr/bin/php70 artisan ninja:send-invoices

Thu, 12 Apr 2018 13:02:12 +0000 Running SendRecurringInvoices…
3 recurring invoice(s) found
Processing Invoice: 1124
Not billed - Sending Invoice
0 due recurring invoice instance(s) found
0 recurring expenses(s) found
Thu, 12 Apr 2018 13:02:33 +0000 Done

Thank You For All

Glad to hear it’s working!