Problem viewing invoice on self-host

Hi. “View as Recipient” and the clients email link both go to the account login page, instead of seeing the clients invoice. Please help. Thanks.

If you could post (or email us) an example link we’ll try to help track down the problem.

I just sent you an email. Thanks.

Thanks for your help, you guys are great! :slight_smile:

same problem here… can you assist me as well?

(very nice product by the way ) :slight_smile:

If you have any values set for subdomain or website on /settings/email_settings try clearing it

I run the website on port 81 on the internet and do NAT to the invoiceninja server ( which is a bitnami installation) running on port 80

in the config I changed the “application settings” to
If I don’t adjust that it wil use port 80 which is another webserver.

The previous version I used was working correctly

Check the port is set in APP_URL in the .env file or on the System Settings page.