Problem after update to 3.3.3

Hi,

Today I upgraded to 3.3.3 (backup .env, overwrite files, navigate to /update, cleared cache).
I am able to login and see the list of my invoices and clients. When I open an invoice (/invoices/##/edit), the invoice table is empty, and the invoice preview doesn’t load. I get no errors in /storage/logs, but my console shows 2 errors:

-edit:3889:8: unreachable code after return statement
-edit:3215:21: ReferenceError: getContactDisplayNameWithEmail is not defined

Line 3889 contains: var number = ‘F/2017116’;

Could the backslash cause the problem? It didn’t cause any problems in the previous versions.

Kind regards,
Tom

EDIT: I changed the invoice pattern to F2017116, and tried to create a new invoice, but the problem persist. (same errors)

Thanks for the error details!

Can you try force refreshing the browser page, maybe the JavaScript files are cached locally.

I reloaded the page, tried in incognito mode, and changed browser, but the problem persists.
If necessary, I can PM you with login details.

If you can send the login details for the app to contact@invoiceninja.com I’ll try to debug it.

I just discovered the problem. I had updated /ninja, but the public folder is in /subsites/invoice. I forgot to update the public folder. Works fine now.
Sorry to disturb you.

No worries, great to hear!