Partial_due_date as replacement of Due_date

Hello,

My workflow is as follows: The client receives a quote with a partial deposit amount as payment in advance. The way they can accept the quote is by paying the advance.

The issue: When setting up a partial deposit amount the field ‘partial due date’ cannot be empty and has to have a date prior to the ‘valid until’ date. So I have to set the ‘partial due date’ 1 day earlier but i wish it to be the same day.

How can I achieve this?
I have tried to set the ‘valid until’ date to display:none and ‘partial_due_date’ to show/display on quote.
This results to either show both dates (which is confusing) or none at all as the ‘selector’ is the same (as I understand: $due_date)

Hi,

@david thoughts on making the partial due date optional? I believe it was optional in v4.

Hi @hillel
It still is optional but when you set the ‘partial deposit’ you have to set ‘partial_due_date’ as well. Which would be fine as long as I can display solely that date as the ‘valid until’ date.

Another way would be to not have the ‘valid until’ date as a requirement. That does not matter to me as long as i can display the ‘partial due date’ as the ‘valid until date’.

Hope it makes sense

The valid until date isn’t currently required?

Yes it is required, which makes total sense but the ‘partial_due_date’ is also required when you set a ‘partial deposit’ amount.

Maybe it does not matter at all, as I think it over. When the ‘partial_due_date’ expires does that label the quote as ‘expired’ as well?
If it does not, the easiest solution would be to just not display that date and it would not matter when that date expires.

and what would happen in the customer portal when ‘partial_due_date’ expires? Can the client still see the amount and go through the payment process for "partial deposit’ amount

Not sure, I’m able to create a quote without setting the valid until date.

@david can you please advise on the client portal?

This is what I get:
Selection_001

To be sure I removed the ‘default’ “valid until” to set that to ‘null’. It does not make a difference.

version: v5.10.4-C160

Yeah, same problem here.
Suddenly this is required.
Please change it back to optional so we do not need to fill in that date.
125

I just made ‘bug report’ on this @github. It might have to be in the ‘feature request’ category. If so, i’ll correct that.

@david Do you have a possible solution to this issue?

There are some edge cases around due_dates / partial due dates.

I’ve updated the validation around this, but this may require some additional updates to ensure we do not fix one thing, and break another.

Thanx! Good to hear updates are on their way! :slight_smile: