One user sees another user's tasks

Since this is the first time I am making use of the multi-user feature (self hosted), I was surprised to find that the second user I created had access to all of the first user’s tasks. Is this normal?

Ideally, each worker would only see their own tasks, right?

Is there no way to restrict this?

And secondly, it appears I am only able to restrict this second user from seeing projects or customers, but I can not, for instance, allow them to see customer and project names without them also seeing rates…
How do I allow a contractor to select customer and project for their task without also having access to project rates?

Is it possible to restrict visibility per project or is it just all projects or none?

Thanks -


The permissions should allow users to only see tasks they create.

The app doesn’t support showing partial record data.


Where do I control which tasks they will see then?

Presently both users see both users’ tasks. How do I set it so that the second user only sees their own tasks, and the first user sees both?

Click the user on Settings > User Management, you can enable create, view and/or edit.


But how do I control whether or not the second user sees only his own tasks versus everyone else’s?
Presently this second user is seeing my tasks as well as his own. How do I disable them seeing my tasks, but leave their own task view enabled?

I do not see an option that controls that.

You said each user should only see their own tasks, this is not the case on my system. I see all tasks, and he does as well.

I want a situation where he only sees his own tasks, but I see all tasks (mine and his), since I need to be able to see his tasks in order to invoice clients for them.

How do I control this?

Hillel stated:
“The permissions should allow users to only see tasks they create.”

This is not the case on my system. With default self hosted configuration, both users see both users’ tasks.

How do I fix this?

Is the second user an admin?

He only has full permissions to see Tasks (all three boxes checked - Create, View and Edit).
All other boxes are unchecked.

You’d want to uncheck ‘view’ for tasks if they shouldn’t see all tasks