OLD PHP CLI version Fatal error: Composer detected issues in your platform

Hello Dear Community,

i can’t run cronjob by reason of old php cli 7.2.x version

Fatal error: Composer detected issues in your platform: Your
Composer dependencies require a PHP version “>= 8.1.2”. You are
running 7.2.34-nmm8. in
…/websites/invoiceninja/in5.7.61/vendor/composer/platform_check.php
on line 28


Bildschirmfoto 2023-12-12 um 11.02.11

Has sombody a ideea?
thanks in advance

Hi,

It looks like you need to upgrade your PHP CLI version.

Thank you for your reply.
But when I type “shell php -v” it shows me PHP 8.1.22 (cli). I did the reset to php 8.1.22 and terminal shows me that too. I may have to specify the version in composer.json

@david do you have any suggestions?

add “platform”: {“php”: “8.1.22”} to composer.json didn’t help