Not Reading .env file

I have installed a new Invoice Ninja and i have entered my white label key i have changed the .env file to

#options - snappdf / phantom / hosted_ninja
I have then used the update secret and when i check the Health Check or create a invoice it is still using phantom JS.

Any help would be great


It may help to load /update?secret=

I have already done this, I even enabled bugging in the .env file and nothing happened here also.

Do you have any access to terminal? or any cli?

if you have them, have you run “php artisan optimize” on the app folder?

if you didnt know how to run that command answer the following question;
Are you on Shared Hosting or VPS?
Do you have cpanel?

Yes I am on Shared Hosting
It is there own version of Cpanel

Do you have this?

if yes, then click it, and run this command

cd / path to your app && php artisan optimize

For example as per follows;

*If you put app inside subfolder
cd /home/username/public_html/yourdomain.comFolder/invoiceninja && php artisan optimize

*if you put app on you domain
cd /home/username/public_html/yourdomain.comFolder && php artisan optimize

you should get the following result;


if you dont get this result, please check your /storage/laravel.log and paste content within here.

1 Like

It does not have Terminal :frowning:

You can open ticket on your hosting and ask them to do it for you.

But prepare every info like where your invoiceninja are installed, and where you want them to run the command and what command.

Or maybe you can copy this forum link and sent it to them (Your hosting).

Most of the time, they will do it for you with not so many question asked, and you can also ask them if they can enable terminal for your cpanel account.

additional info on invoiceninja v5 installation documentation can be found here ; Free Source Available Invoicing, Expenses & Time-Tracking | Invoice Ninja

It may help to delete the bootstrap/cache folder

I’d double-check file ownership and permissions. if the .env isn’t readable, well, that’d give you your answer.