Not able to use variables during customization

I just tried to customize my first quote and I tried to put some text in Settings > Company details > Default > Quote terms > Quote footer:

<div><strong>$number</strong></div>
<div><strong>$quote.number</strong></div>

The content above displayed just:

$number
$quote.number

… within the generated PDF.

Hi,

Thanks for reporting this!

cc @david @ben

Cannot recreate this. Are you saving a new template and then setting this template when you create the quote?

I modify my Quote footer via:
Settings > Company details > Default > Quote terms > Quote footer

Right after that I proceed with creating new quote, then I add just a few items and click Save. When I download the PDF, there are $number variables that are not converted into the real quote number, so the output OF THE QUOTE FOOTER looks like this:
Quote number: $number

… instead of looking like this:
Quote number: 12345

@Jazz

Righto, that would require us to do a double pass over the variables which we don’t currently support. ie Replacing a variable with a set of other variables.

Yeah, within the footer of all my quotes there should be a box with the Payment data, e.g.:

Bank account: 123456789 <--- just a regular text
Reference: $number <--- Quote number (must be a variable, obviously)

Without this, it’s difficult to use InvoiceNinja if we can’t tell the customers how to pay for our Quotes via bank transfers. Unless there’s a workaround for this usecase?

You could hardcode the references in the template itself, for example in the footer tab.

1 Like

I can confirm this workaround fixes the issue (at least as a temporary solution).

1 Like

I just found out when using your workaround I have a double footer when converting Quotes to Invoices:

There’s still the Quote footer followed by the Invoice footer right below.

Would be more appropriate to ignore the Quote footer content (on Invoices) automatically during such conversion, no?

I think you may be able to use $entity.footer

this will give you the entity specific footer, i haven’t tested it, but it should work.

1 Like