No way to add link in invoice email

Trying to modify the WYSIWYG invoice email in IN 5 and adding a link seems impossible. ENTER doesn’t do it, clicking outside after pasting doesn’t do it. I also see no way to edit the source like it used to be. This seems like a large barrier to an important function. :frowning:


Also - Dates in an invoice in the Web Interface. They jump all over the place from year to year. This is an example. I was unable to set this date to the date I wanted. The date picker was even worse with links in the wrong place and having no effect.



You should be able to use enter to apply the link, I’ll do some testing. As a workaround you can disable the WYSIWYG editor on Settings > Account Management.

Which date format do you have selected on Settings > Localization?

Sorry about the delay… busy these days :frowning:

My Date format is : 31/01/2000

As things are now - version: v5.3.96-W84, Docker

Selecting text and the menu provides no option to add a link:

When I add a link via markdown, there’s no representation of this in the preview window (so if I guess it’s going to work, I can’t trust it in the moment to be honest):

At this point, the interface has no way to change or update an external link (that I can see or trust).

Going to Settings → Account Management there is nothing that says “WYSIWYG” editor, but maybe you mean Enable Email Markdown? I’ll disable that. Really not great text in English, “Enable WYSIWYG Editor” would have actually made more sense.

Going back into a new email, I now see my default link and even markdown set in the template, but still, the preview shows no representation (not blue, not red, no underline, not clickable) that this will be a link - so I still don’t really trust this will work. I do remember this cue was there so at least I knew the link was added (otherwise, why bother preview?).

I guess I’ll test this on a client. I never like to be embarrassed when my systems don’t work.

Just a follow-up - I just went ahead tried it… emailed the client… and the link seemed to come through when I used direct markdown like this:

Here is the resulting email and the link looked correct:

Thanks for the feedback!

We plan to release a new version of the Windows app next week which will support adding links with the WYSIWYG editor. We’ll also look into clarifying the text.