No Login after Update to v5.1.32

After Update from v5.0.45-C37 to v5.1.32 there is no login possible.


There is no errorlog without this:
production.ERROR: Class ‘App\Jobs\Invoice\CreateEntityPdf’ not found {“exception”:"[object] (Error(code: 0): Class ‘App\Jobs\Invoice\CreateEntityPdf’ not found at /html/invoiceninja/app/Console/Commands/SendTestEmails.php:148)

The file permissions are set correctly, otherwise the login with v5.0.45 would not have worked either.


The latest version is v5.1.41, do you want to see if it helps?

Thank for information, but how you can see in my screenshot there will only be update to v5.1.32.

Therefore I tried a manual update (like before under v4). So downloaded v5.1.41 and replaced the “.env”. But that did not work either.
Then I emptied the database and reinstalled v5.1.41 via setup. This does not work either, because the user is not created in the database:

production.ERROR: ***ErrorException*** [0] : /html/ninja-5-1-42/app/Models/Account.php [Line 1126] => Unparenthesized a ? b : c ?: dis deprecated. Use either(a ? b : c) ?: dora ? b : (c ?: d) {"context":"PHP","user_id":0,"account_id":0,"user_name":"","method":"GET","user_agent":"...","locale":"en","ip":"...","count":4,"is_console":"no","is_api":"no","db_server":"mysql","url":"setup"} []

Now I am at the end of my latin.
How can I upgrade from v5.0.45 to v5.1.41?

What version of PHP are you using?

@david any thoughts on the error?

looks like a php version issue.

I tasted it with PHP 7.3 and 7.4