Ninja invoice company document upload Error: please check that Invoice Ninja v5 is installed on the server

ninja invoice company document upload Error: please check that Invoice Ninja v5 is installed on the server

image

Hi,

Are there any details about the error in storage/logs/

@david any thoughts?

I’m not sure, it may help to check the browser console for additional information. but most certainly a configuration issue with the server.

No log, no errors when we uploaded.

Hi Devid,

Below is the error screenshot when i tried to upload document for company

Also i have created subdomain to configure this application on server

http://ninjainvoice.premieretechgroup.com/

I have 1 question when i go to https://app.invoiceninja.com/ to our test drive i found that we are not using public/ folder

So my question is should i remove public folder too from my server ?

Going to attact my .htaccess file from root and public/ folder please review both and let me know if there is causing any issue

I am sure i made correct db connection setting so i guess there should not be any issue from db connection

Also attached screen for installed ninja version

Please give me the reference document url where i can cross verify the installation process.

Please help me to resolve issue as soon as possible, I will be more happy if your team help me to resolve those issue!

Regards,

.htaccess_public_folder_file

SecFilterEngine Off SecFilterScanPOST Off Options -MultiViews -Indexes
RewriteEngine On

# Handle Authorization Header
RewriteCond %{HTTP:Authorization} .
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

# Redirect Trailing Slashes If Not A Folder...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} (.+)/$
RewriteRule ^ %1 [L,R=301]

# Handle Front Controller...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php [L]
# Blocks Search Engine Indexing Header set X-Robots-Tag "noindex, nofollow"

.htaccess_root_folder_file

SecFilterEngine Off SecFilterScanPOST Off RewriteEngine On RewriteRule "^.env" - [F,L] # RewriteRule "^storage" - [F,L] RewriteRule ^(.well-known)($|/) - [L] RewriteCond %{REQUEST_URI} !^public RewriteRule ^(.*)$ public/$1 [L]

server-configs-apache/.htaccess at master · h5bp/server-configs-apache · GitHub

# INTERNET EXPLORER

----------------------------------------------------------------------

| Iframes cookies |

----------------------------------------------------------------------

Allow cookies to be set from iframes in Internet Explorer.

https://msdn.microsoft.com/en-us/library/ms537343.aspx

The Platform for Privacy Preferences 1.0 (P3P1.0) Specification

Header set P3P "policyref=\"/w3c/p3p.xml\", CP=\"IDC DSP COR ADM DEVi TAIi PSA PSD IVAi IVDi CONi HIS OUR IND CNT\""

# MEDIA TYPES AND CHARACTER ENCODINGS

----------------------------------------------------------------------

| Character encodings |

----------------------------------------------------------------------

Serve all resources labeled as text/html or text/plain

with the media type charset parameter set to UTF-8.

core - Apache HTTP Server Version 2.4

AddDefaultCharset utf-8

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Serve the following file types with the media type charset

parameter set to UTF-8.

mod_mime - Apache HTTP Server Version 2.4

AddCharset utf-8 .atom \ .bbaw \ .css \ .geojson \ .js \ .json \ .jsonld \ .manifest \ .rdf \ .rss \ .topojson \ .vtt \ .webapp \ .webmanifest \ .xloc \ .xml

# WEB PERFORMANCE

----------------------------------------------------------------------

| Compression |

----------------------------------------------------------------------

# Force compression for mangled headers.
# https://developer.yahoo.com/blogs/ydn/pushing-beyond-gzipping-25601.html

<IfModule mod_setenvif.c>
    <IfModule mod_headers.c>
        SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
        RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
    </IfModule>
</IfModule>

# - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

# Map certain file types to the specified encoding type in order to
# make Apache serve them with the appropriate `Content-Encoding` HTTP
# response header (this will NOT make Apache compress them!).

# If the following file types wouldn't be served without the appropriate
# `Content-Enable` HTTP response header, client applications (e.g.:
# browsers) wouldn't know that they first need to uncompress the response,
# and thus, wouldn't be able to understand the content.

# http://httpd.apache.org/docs/current/mod/mod_mime.html#addencoding

<IfModule mod_mime.c>
    AddEncoding gzip              svgz
</IfModule>

# - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

# Compress all output labeled with one of the following media types.

# IMPORTANT: For Apache versions below 2.3.7 you don't need to enable
# `mod_filter` and can remove the `<IfModule mod_filter.c>` & `</IfModule>`
# lines as `AddOutputFilterByType` is still in the core directives.

<IfModule mod_filter.c>
    AddOutputFilterByType DEFLATE "application/atom+xml" \
                                  "application/javascript" \
                                  "application/json" \
                                  "application/ld+json" \
                                  "application/manifest+json" \
                                  "application/rdf+xml" \
                                  "application/rss+xml" \
                                  "application/schema+json" \
                                  "application/vnd.geo+json" \
                                  "application/vnd.ms-fontobject" \
                                  "application/x-font-ttf" \
                                  "application/x-web-app-manifest+json" \
                                  "application/xhtml+xml" \
                                  "application/xml" \
                                  "font/opentype" \
                                  "image/svg+xml" \
                                  "image/x-icon" \
                                  "text/cache-manifest" \
                                  "text/css" \
                                  "text/html" \
                                  "text/javascript" \
                                  "text/plain" \
                                  "text/vtt" \
                                  "text/x-component" \
                                  "text/xml"
</IfModule>

Hi @david @hillel

I need your help on above specified issue.

Thanks
PTG

@PTG I had the same issue or similar issue. My issue was a 413 which I solved. From your picture it looks like your getting a 403 error which is a server permissions error. You should check to make sure that you have the correct ownership and permissions for the webroot and all included directories. Unsure if you are running Apache or NGINX but there are tutorials available.

For self-hosted yes you should have the public folder and that is where your webserver root should be serving from.