Need help with V5 installation

I’ve been trying to do a migration from v4.5.38 to latest version of v5.
The migration keeps failing.

The email notification says the following.
Undefined index: ninja_tokens
Undefined index: ninja_tokens

What are the steps for a manual migration?


The latest v4 is v4.5.49, upgrading may help.

Hi, I tried updating to the 4.5.49.
Now I’m getting a 500 Server error.
The .env file is the same. Just replaced all the old files with the new files except for .env and /storage/documents.

[autoindex:error] Cannot serve directory /home/dcladmin/webapps/app-invoiceninjav4/: No matching DirectoryIndex (index.html,index.php,index.php2,index.php3,index.php4,index.php5) found, and server-generated directory index forbidden by Options directive

I’m not sure, you may want to setup a clean v4 install and copy over the .env file and database using mysqldump.

I’m at a loss. I downloaded the 4.5.49 zip file.

  • Deleted all the other files in the webapp folder.
  • Uploaded the zip file, unzipped.
  • Using a subdomain.
  • Clean database.
  • Can’t access the install window for Invoice Ninja.
  • 500 server error.
  • So I copied the .env file over.
  • Still error.
  • Uploaded the database from mysql dump.
    Still. :frowning:
    Feeling like about to give up. But I need to access my data, clients, invoices, e.t.c.

Is there anyone who can help me? will pay for your time.


RewriteEngine On
RewriteRule “^.env” - [F,L]
RewriteRule “^storage” - [F,L]
RewriteRule ^(.well-known)($|/) - [L]
RewriteRule ^(.*)$ public/$1 [L]


If you see a 500 error there should be more details in storage/logs or the web server error logs

I managed to get into the dashboard

I reset the db password which seems to fix the connection issue.

Now when I click on Settings in the dashboard, it says
Not Found
The requested URL was not found on this server.

Have you made any changes to the code or is it a clean install?

Clean install.
Okay I uncommented the RewriteRule ^(.*)$ public/$1 [L] in the htaccess file. That seems to have fixed that error of URL not found.

I’m going to try the migration

What PHP version are you using?

Using php 7.4

The migration worked. I’m now on v5.