Missing languages & currencies


I’ve just installed v5 following the docker-compose instruction, and so far everything seems to be up and running fine.

Trying to change my language as well as currency I’ve run into the first problems though - there’s just roughly 7 languages/currencies to pick from, exotic ones on top of that, like Arabic/Bulgarian/Latvian/Slovak/… & Cambodian Riel/Cuban Peso/Cayman Island Dollar.

I myself need German and € - did I missing something during installation, or is there a way to get all those missing translations/currencies?

Thanks in advance!


@david any thoughts?

1 Like

I would try to clear the cache by going to this URL in your browser.


1 Like

I have seen this in the past and it helped to delete cache and click the “X” at the dropdown menu. It than showed much more options, including Euro.

1 Like

Clearing the cache with the URL mentioned by david was indeed the solution!

Thanks a ton for the lightning-quick response and solution!

this is not working on unraid… any other solutions…?


The solution should work across all platforms.

One thing to check is that the currencies table is fully populated in the database, there should be > 110 records.

yep it have 113 records
and lang has 37

Have you tried clicking the x to clear the current selection?

Just did a fresh install via docker-compose on Ubuntu - with the same problem again.
Upon first start, there’s just the handful of languages to choose from, needing to clear the cache to have all languages available.