Migration not starting

Hey guys,

thanks for this great pice of software.
I try to migrate from v4.5.18 to v5.1.70-C51.

On my new v5 instance the cron job is running smoothly and after the migration is starting from v4 the only thing that happens is that a new .zip file is created with a json file in it that i not can manully imported into the v5 instance.

All the laravel.logs are empty and clean.


Thanks :slight_smile:

I suggest updating the latest v4, there have been many migration related fixes since then.

i tried to update but ended up in a total crash - where do I get the latest v4 version?


is there a simple way to update?
Last try i simply upload all the new files and got so many errors.

You could setup a new install and copy over the database and .env file

puh alright - I give it try with a new instance for the second v4 version

and the same error awaits me after the update to the latest v4 version:

Fatal error: Uncaught Dotenv\Exception\InvalidFileException: Dotenv values starting with a quote must finish with a closing quote. in /www/htdocs/w00e0e56/invoice/v4539/vendor/vlucas/phpdotenv/src/Parser.php:98 Stack trace: #0 /www/htdocs/w00e0e56/invoice/v4539/vendor/vlucas/phpdotenv/src/Parser.php(41): Dotenv\Parser::parseQuotedValue(''-----BEGIN CER...') #1 /www/htdocs/w00e0e56/invoice/v4539/vendor/vlucas/phpdotenv/src/Loader.php(238): Dotenv\Parser::parseValue(''-----BEGIN CER...') #2 /www/htdocs/w00e0e56/invoice/v4539/vendor/vlucas/phpdotenv/src/Loader.php(152): Dotenv\Loader->sanitiseVariableValue('SSL_SERVER_CERT', ''-----BEGIN CER...') #3 /www/htdocs/w00e0e56/invoice/v4539/vendor/vlucas/phpdotenv/src/Loader.php(129): Dotenv\Loader->processFilters('SSL_SERVER_CERT', ''-----BEGIN CER...') #4 /www/htdocs/w00e0e56/invoice/v4539/vendor/vlucas/phpdotenv/src/Loader.php(325): Dotenv\Loader->normaliseEnvironmentVariable('SSL_SERVER_CERT...', NULL) #5 /www/htdocs/w00e0e56/invoice/v4539/vendor/vlucas/phpdotenv/src/Loader.php in /www/htdocs/w00e0e56/invoice/v4539/vendor/vlucas/phpdotenv/src/Parser.php on line 98

Do you have a missing quote in the .env file?

You may want to try starting from the default env.example file

now i got it working and succefully migrated to v5.
Did have to deactive the SSL certificate.
But now v5 wants to activate my migrated company and needs a token?

In v5 the company is de-activated by default so reminders and recurring invoices aren’t sent from both apps. You can activate on Settings > Account Management.

I’m not sure what you referring to about the token, can you please clarify