Migration fails v4 -> v5

hi,

i use both versions self-hosted, installed from scratch via zip-file.

v4 is v4.5.50, v5 is v14.04.2024.1, both are licensed.

i used the normal way via app, log looks good until i get an email telling me something went wrong.

version 4  // tail -f laravel-info.log
[2024-05-29T13:08:45.331022+00:00] production.INFO: get recurring Expenses => 0 [] []
[2024-05-29T13:08:45.335185+00:00] production.INFO: get recurring invoices => 17 [] []
[2024-05-29T13:08:46.412216+00:00] production.INFO: get quotes => 21 [] []
[2024-05-29T13:08:46.487363+00:00] production.INFO: get payments => 572 [] []
[2024-05-29T13:08:47.129859+00:00] production.INFO: get documents => 397 [] []
[2024-05-29T13:08:47.199719+00:00] production.INFO: get expense categories => 0 [] []
[2024-05-29T13:08:47.200745+00:00] production.INFO: get task statuses => 8 [] []
[2024-05-29T13:08:47.202835+00:00] production.INFO: get expenses => 0 [] []
[2024-05-29T13:08:47.204743+00:00] production.INFO: get tasks => 106 [] []
[2024-05-29T13:08:47.234959+00:00] production.INFO: get documents => 397 [] []
version 5 //  tail -f laravel.log
[2024-05-29 13:08:49] production.INFO: Importing payment_terms
[2024-05-29 13:08:49] production.INFO: Importing tax_rates
[2024-05-29 13:08:50] production.INFO: Importing clients
[2024-05-29 13:09:17] production.INFO: Importing company_gateways
[2024-05-29 13:09:17] production.INFO: Importing client_gateway_tokens
[2024-05-29 13:09:17] production.INFO: Importing vendors
[2024-05-29 13:09:17] production.INFO: Importing projects
[2024-05-29 13:09:19] production.INFO: Importing products
[2024-05-29 13:09:21] production.INFO: Importing credits
[2024-05-29 13:09:23] production.INFO: Importing recurring_invoices
[2024-05-29 13:09:33] production.INFO: Importing invoices

mail says: Missing resource key: recurring_invoices_16

i have absolute no idea what’s wrong… :-/

cheers, chris

Hi,

Maybe this will help:

1 Like

hey :slight_smile:

i did not delete anything in the database directly. i only use the app for everything i have to do in invoceninja.

greetings, chris

@david do you have any suggestions?

hey there again :wink:

i installed phpmyadmin and checked the tables - there was indeed an invoice with rec. invoice # 16 in the invoices. but i am 100% sure that i never deleted anything from database. i dont know, hot it happens, but deleteing the corresponding invoice helped. so: thanks a lot!

not i run into a “gateway timeout”, but thats a different problem :wink:

thx, chris

1 Like

Glad to hear it, thanks for the update!