Migrating V4 (manual install) to v5 Docker

Hey guys,

I’m trying to migrate my v4 installation into a V5 Docker installation. Both running on the latest version (4.5.34 and v5.1.26-C44).

When i start the migration i get the following error:
Oops, something went wrong! Please make sure you have setup an Invoice Ninja v5 instance before starting the migration.

and in the log i can see the following:
[2021-03-17 11:37:28] production.INFO: Undefined property: stdClass::$data [] []
[2021-03-17 11:50:44] production.INFO: Undefined property: stdClass::$data [] []
[2021-03-17 13:59:40] production.INFO: Undefined property: stdClass::$data [] []

I found the following issu on github:

But im not using any API_SECRET in my installation (or i can’t see any).

Any help would be appreciated


We just release v4.5.35, it’s possible it may help.

@david, do you recognize “Undefined property: stdClass::$data [] []”


I think this error means the migration file is corrupt, if you navigate to storage/migrations in V4 there should be a zip file there, unzip and inspect the data - there may be more an error sitting in there.

1 Like

I had some issues with migration also, but I worked around it with CSV exports and imports from v4 to v5 which worked to transfer all my clients, invoices, and expenses. It’s only basic data fields right now but it might be enough for you if you just wanna work around it. Do one single csv import at a time on v5 for it to succeed, and make sure to map every field from the import file to a corresponding field on the new DB. You’ll see when you go to import…

@TechnicallyComputers I saw the cab import and gave it a try but mapping all the fuels was no option.
If everything fail I will give it a try but for now I will stick for what @david said :wink:

But thanks for the tip :+1:

Not sure what did the trick but after updating to v4.5.35 it went through :wink:
But there was a old migration file under /storage/migration" so maybe it was a mix of booth :+1:

1 Like