Migrated to V5 - Self-Hosted on cPanel - No Email

I created a new hosting environment in cPanel. I installed V5 using Softlicious. I used same login credentials, then ran the migration.
Everything completed successfully, and the new platform is up. I cannot get it to send emails, however. Prior to the migration, I was using PostmarkApp to track send/bounce/open, etc.

Nothing in the logs besides these two entries from yesterday:

[2021-12-12 00:00:04] production.INFO: updating currencies
[2021-12-12 00:30:03] production.INFO: Performing Autobilling 2021-12-12 12:30:03

I have ran these commands:

billingthedillde@chir115 [~/public_html]# php artisan migrate
**************************************
*     Application In Production!     *
**************************************

 Do you really wish to run this command? (yes/no) [no]:
 > y

Nothing to migrate.

billingthedillde@chir115 [~/public_html]# cd /home/billingthedillde/public_html/ && php -d register_argc_argv=On artisan schedule:run
No scheduled commands are ready to run.

billingthedillde@chir115 [~/public_html]# /opt/alt/php74/usr/bin/php /home/billingthedillde/public_html/artisan ninja:send-reminders

Here is my current .env:

MAIL_MAILER=smtp
MAIL_HOST=smtp.postmarkapp.com
MAIL_PORT=587
MAIL_USERNAME=xxx-1909-4e48-b1a9-xxx
MAIL_PASSWORD=xxx-1909-4e48-b1a9-xxx
MAIL_ENCRYPTION=tls
MAIL_FROM_ADDRESS='service@xxx.com'
MAIL_FROM_NAME='xxx Billing'

POSTMARK_API_TOKEN=xxx-1909-4e48-b1a9-xxx
REQUIRE_HTTPS=true

These values are pulled from Postmark portal, and I have also tried with only POSTMARK_API_TOKEN set and no SMTP configuration. I have also changed the settings under Settings > Email inside of the app.

I fought this same thing for hours the other night. One thing I will say I found, when installed with Softalicious, the email settings that are asked for under Advanced have to be right. One thing I noticed, if I didn’t have those right, no matter how many times I changed the .env config file, it never worked. i feel like the install isn’t able to restart and reprocess any changes after it’s initially installed. Once I verified all settings, reinstalled with the exact proper settings , it magically started working. There was one other thing I had to add to the mail config file related to SSL cert. If you think that might be related, I’ll find it. Go to Dashboard, and click Activity at the top and see what the error is on send mail, if it’s same as I was getting i’ll get you that code.

I think I got it, thanks! I completely removed the .env SMTP settings, and also cleared out Email Settings. Set everything up fresh, and confirmed my queue was working and cron was setup. After that, I got a dump of emails and even see their status in postmarkapp.

What do you have set for your webhooks in Postmark?

https://subdomain.domain.com/webhooks/email_bounced and email_opened ?

I do have pending jobs now though: https://i.imgur.com/18Op23N.png

It looks like you’ve enabled the queue (it’s set to database), maybe the queue isn’t running?

Note: you can disable the queue by setting it to sync in the .env file.

Honestly, I guess I don’t know what the queue is or why I need it. On version 4 for several years email was sent out through a cron job set to repeat every hour.

The queue is optional and will improve the performance of the app.

You can disable it by changing from database to sync in the .env file.

https://invoiceninja.github.io/docs/self-host-troubleshooting/

I mean, if I disable the queue will emails still be sent? When I disable the queue, I still get pending jobs orange triangle.

Other issues since the move to V5: the pay now button in an invoice drops down an empty box:

image

When attempting to go to the client portal:
image

All the modules are enabled, and client portal is setup:

I am happy to pay for support if anyone is available to help me fix these things.

If you disable the queue future emails should send immediately but I don’t believe past queued emails will be sent.

@david @ben any thoughts on the other issues?

This is error in console on the invoice pay now page, which I tried with 3 different versions of browser.


image

Also seeing this…

image

What a wreck this is.

@imburr

Can you confirm the APP_URL in your .env matches the URL you use to access the application?

I would suggest using QUEUE_CONNECTION=sync until the other issues have been ironed out.

In regards to the payment gateway not displaying, can you confirm the gateways have payment methods enabled on the settings page? Also, some gateways are limited by the clients location so if the client is not in a region (or uses a supported currency) then the gateway will not show.