Lost admin privileges after upgrade

Hi ,
I upgraded using softaculous.com to and lost admin privileges. Now I can’t go to settings at all . my account became regular user account . Please help. I have self-hosting option , white labeled .

It sounds like the database migrations didn’t complete, you can try running them manually by loading /update in your browser.

I tried that and I get in the browser.

SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘fonts’ already exists (SQL: create table fonts (id int unsigned not null auto_increment primary key, name varchar(255) not null, folder varchar(255) not null, css_stack varchar(255) not null, css_weight smallint not null default ‘400’, google_font varchar(255) not null, normal varchar(255) not null, bold varchar(255) not null, italics varchar(255) not null, bolditalics varchar(255) not null, is_early_access tinyint(1) not null, sort_order int unsigned not null default ‘10000’) default character set utf8 collate utf8_unicode_ci)

From the error it looks like the problem was with the following migration.


Please try commenting out the first and then second parts of the up function and try again.

This is what I have . Which part exactly should I comment out ?


use Illuminate\Database\Migrations\Migration;

class AddInvoiceFontSupport extends Migration
* Run the migrations.
* @return void
public function up()

    Schema::create('fonts', function ($t) {

    // Create fonts
    //$seeder = new FontsSeeder();

    Schema::table('accounts', function ($table) {

    Schema::table('accounts', function ($table) {

 * Reverse the migrations.
 * @return void

public function down()
    if (Schema::hasColumn('accounts', 'header_font_id')) {
        Schema::table('accounts', function ($table) {

    if (Schema::hasColumn('accounts', 'body_font_id')) {
        Schema::table('accounts', function ($table) {



Try removing:

Schema::create(‘fonts’, function ($t) {

If it still fails then remove:

Schema::table(‘accounts’, function ($table) {

thank you, it worked after removing both. should i put the code back now or just leave it the way it is ?

You can leave it the way it is.