It tells me that the crones are not active but then in the test it says they are

I have a problem with my Invoiceninja, it indicates that the crones are not enabled, however if I do the corresponding test it tells me that they are.

This is causing me to be unable to send invoices to customers directly to their email from Invoice Ninja.

I share screenshots


erro2

Hi,

What’s your cron configuration?



Both bash.sh and cron1.sh look wrong to me. The first has “/path/to/root/folder” and the second has an invalid cd command. I suggest first running the schedule:run command from the CLI to ensure it’s correct.

What would be the correct command, unfortunately Hostinger does not allow me to do it in any other way, if you could provide me with the correct command it would be better for me.

Thanks for your time

Please copy/paste cron1.sh here and I’ll try to correct it

cd //usr/bin/php /home/u704214987/domains/un2connect.es/public_html/zapecms && php artisan schedule:run >> /dev/null 2>&1

I’m not sure if it will work but try:

cd /home/u704214987/domains/un2connect.es/public_html/zapecms && /usr/bin/php artisan schedule:run >> /dev/null 2>&1

I get the same error “crons must be enabled” and the red triangle does not disappear.
Maybe the error is also in this line

cd /path/to/root/folder && /usr/bin/php -d register_argc_argv=On artisan schedule:run >> /dev/null 2>&1

That command won’t work, /path/to/root/folder doesn’t exist.

Why are there two files? You should just need one.

Right now I have it all in one file, but it still doesn’t work and I don’t really know what else to do to make the cron work and appear in Invoice Ninja activated.

I’ve tried everything I can see on the help forum and nothing works. Do you have any idea how to fix it and get it working?

What do you mean by “all in one file”? Can you please copy/paste the file here.

Is there a reason for the second line, I don’t think it’s correct or needed.

I have deleted the second line, but the error is still not fixed.

Sorry, I’m not sure, Our general advise is to run the command from CLI to ensure it’s correct but I realize that isn’t possible here.