iPhone, Expenses, Camera


I am using self-hosted 4.5.16 (everything appears to be working fine)
iOS 12.4 on iPhone

When clicking the camera app inside of expenses, the app crashes. I took a look inside the privacy settings thinking maybe the app didn’t have permissions to use the camera, however, the app doesn’t even show the option to allow it to see the camera under the privacy and camera settings locations.

Anyone else having problems with this?

The app should ask for permission the first time you use the camera, maybe try reinstalling the app?

Just uninstalled and reinstalled, never asked for camera access. Went to expenses and tried to launch the camera, the app crashes.

Again under Privacy > Camera > InvoiceNinja is not listed

Which exact version of the mobile app are you using?


Sorry, I’m not sure. I haven’t been able to reproduce the problem.

I just updated to 13.3 (17C54) tonight, uninstalled, reinstalled and I’m still facing the same issue. Mobile application crashes as soon as I click the camera icon. Still no sign of it in the privacy > camera page.

Here is everything showing under the app settings

Do you see the app on Settings > Privacy > Camera at the bottom?

Thanks for your quick reply.

No. It appears to be listed in alphabetical order. The only I is Instagram. Not listed on the bottom either.

Sorry, I don’t have an answer

No problem. Are there any app debugs I can do or anyone in particular I can work with to resolve? I’m sure I can’t be the only one with the issue.

Sorry, not that I’m aware of.

This is the first time I’ve seen this issue, in other cases re-installing the app shows the accept permission popup.

Yeah that is weird. I’ve never gotten any kind of permissions pop-up during any of the installs or at the time the camera launches.

The other weird thing is, there are zero entries for InvoiceNinja in the app data logs in the Privacy > Analytics > Analytics Data page.

Looks like other developers are seeing similar issues with their apps.

My phone from a hardware perspective is an iPhone SE