Invoice Terms Checkbox not showing

I’m running v4.0.1 on CentOS 7 server. I have under “client portal” settings, enabled both Invoice Terms and Quote Terms checkboxes. But when user views their quote, those check boxes are not showing up. Only the “Approve” button is there. The Terms tab on the Quote does have statement added to it. Is there some setting I’m missing? Also, when clicking the view link for the quote it is not forcing a user login and password, just opens up the quote immediately.


The checkbox should be shown after you click approve.

Try testing the link in a different browser to check the user/pass.

Thank you for your response! I tried copying the view link to a new browser. It prompt for password this time, but it still is not showing the checkbox for terms. Just the approve button, after you click on approve it shows message that the quote was successfully approved.
I’ve tried setting text in the Terms on both the Quote and under “Settings->Invoice Settings”.

The default terms on Invoice Settings only apply to new invoices/quotes.

Does the quote you’re testing have terms set?