Invoice Ninja V5 no payment button

I have upgraded to Version 5 and now when creating an invoice an invoice there is no payment button. Also I use invoice Ninja in connection Integromat (setup by 3rd party) that doesn’t work at all.

Any ideas anyone please I am a complete numpty with tech stuff.


Have you added a payment gateway on Settings > Online Payments, also please check if the invoices is marked as sent.

There is a new v5 version of Integormat, can you please confirm it’s what you’re using.


I have sorted the button now. It is not sending invoices now.

I am using V4 with integromat and it works just fine. I want to get V5 working properly before I consider adding to integromat.

To be honest it doesn’t look much different to me. If I didn’t have to change to V5 I wouldn’t bother.

God knows why email not sending all settings seem correct.

Thanks for replying


In v5 we’ve added a system logs feature, do you see the email request there?

When you say the settings are correct which settings are you referring to?

Please find attached the last 1 I tried.
Its was to my email address and neither were received.
I trust this is what you means from Logs

Thanks for the screenshot! It contained your email address so I removed it.

Is it possible the email is in your spam folder?

If you have a Gmail account it’s possible to send from your own address in v5.

No it is not in spam either. To send from Invoice Ninja V5 I am using my domain email. Could that be the problem?

Are you using or are you selfhosting the app?

Yes on the laptop, not the app.

Can you explain what you mean by “using my domain email”?

@david do you have any thoughts?

In the hosted v5 app you can either have emails sent from or using Gmail, sending from your own email would require self hosting the app.

Have you tried sending to more than one test address?

@david may have some other suggestions

So that would be my problem it appears use the from address
I will have a look in the morning, thanks for your time but I have to leave it now, I will update in the morning.

This invoicing is driving me mad. I create an invoice and send but it does arrive and is still showing as draft in the dashboard.
Any ideas welcome.


@david any thoughts?

Also, are you sending the email through the app or are you using Integromat?

@hillel, sounds like the AP is not updating?

Do the activity logs update with the invoice sent message?

Hi, I am sending of my desktop. No there are no sent records in the logs.

I can see the emails are sending from your account,

What happens when you refresh the data in your app in

Settings > Device Settings > Refresh Data

They have sent when I changed to first reminder. Initial email not going. Sorry I’m late it wouldn’t let me reply, ran out of credits.