Invoice Ninja Self Host not working

So I tried setting up invoice Ninja on Ubuntu 16.04. I am still just getting the default apache http page from the server when I try to log in…

Have you mapped the web root to the /public folder?

I did.
I think my problem is that. I used a different guide than the one posted on the IN self-hosting page because of my Ubuntu Server Version. I was a little different. So I have gone back and tried to fill in the blanks. This is the guide I used.

I already had MySQL installed so I used it instead of Mariadb.
The guide had some folder path errors in it that I made sure were correct.
This one does not use the composer build the packages though.
Instead it downloads the packages direct from So I am wondering if something is missing.

If you’re seeing the default apache page I think the problem is likely related to the web server config. If there was a problem with the app files you’d expect to see a 500 error.

Got it working… Kind of… I got to the setup page. Successfully connected to my Database, sent email filled in my user info. I think I messed up the URL settings. because it won’t take me to the login page. How can I get back to modify that?

You can change the settings by modifying the .env file

Yes it was a typo in my default.conf file…


Great! If you can’t see the login I’d suggest checking APP_URL is correct in the .env file.

Now where would the .env be located?

It’s in the root folder of the project, files starting with a dot are sometimes hidden.

Got it thanks.

Oh well thought that’s what was wrong. Still can’t get to the app login…

What do you see?

If I disable HTTPS I can get in.

I guess I need to get a legit security cert for this site before I put any real data in it…

letsencrypt should work…

Thanks. I’ve looked at letsencrypt before but I never followed through. Will revisit Thanks again for your help…