Invoice in language of customer

When I create an invoice, the invoice is created in the language of the user that creates the invoice( from Localisation menu).
( in my case Dutch)

I want to be able to create invoices based on the language of the customer.
I specified the language per customer ( like English), but the invoices are always in Dutch.

What do I wrong?

The live preview is shown in the user’s language however if you click ‘View as recipient’ the invoice should be in the client’s language.

We hope to correct this in the future.

When creating the invoice, I cannot see a ‘View as recipient’ button or link.
When I select ’ send as email’ I get an error message to confirm my e-mail adres ( what adres, where?)

Are you self-hosting or using

If you’re on there should be a ‘Resend confirmation’ button on /settings/user_details

Resend works, thanks
The mail function sends a link to an invoice in the right language. Ok :slight_smile:

Most customers would prefer to have a pdf as attachement: can i configure that the mail is send with an attachement?
Or can I download the attachement ( in create invoice) in the language of the customer?

People who self host or are on the pro plan can attach the PDF on /settings/email_settings

Thanks, I’m on the pro plan. The option is activated ( in settings/email_setting) but no attachement when I send mail.
Do I need to configure the mail template in a specific way?

You should just need “Attach PDFs” checked.

  • Is the PDF preview working correctly when creating/editing invoices?
  • Are you sending the invoice the invoice to yourself as a test client, the invoice isn’t attached to the notification emails.

Yes the PDF preview is working fine.
I send the invoice to another email adres ( not mine) from the invoice menu ( send email).
The email is send ok, but without a PDF in attachement.

I’m not sure… can you try creating as a test client and sending us an invoice.