Invalid file permissions 5.3.44 error 500 after update

wanting to update from 5.3.44.

in health check im am getting

“invalid file permissions” tried running the commands on the info link. still shows invalid.

server error 500 after update.

reverted back to 5.3.44

i ran the health check using the web interface instead of the windows app.
the invalid file permissions is only showing up on the windows app.

is there a procedure to update from 5.3.44 to current. should i upgrade to .45, then .46…

i read of major changes past 5.3.73.


After performing a full backup i would download this release file:

And overwrite all of your existing files with this release.

The self-updater had a major upgrade a few releases ago, so from 5.3.89 onwards the internal updater should be much more reliable.

i copied the VM over to a separate instance. copied 5.3.89 update to directory.

still got error 500

i had to remove composer 1 and install 2 and run " sudo composer require mpyw/compoships-eager-limit"

then /update?secret=

after some time it finally loaded the login screen.

however now testing latest version of windows app gives this error. (not using fqdn but instead ip of test VM)

SocketException: The semaphore timeout period has expired.
(OS Error: The semaphore timeout period has expired.
, errno = 121), address =, port = 51281


Any errors in the logs /storage/logs/laravel.log