Installation error

I am trying to install invoiceninja on my ubuntu vps. I am running apache with varnish. I have done all the steps from the official tutorial, i have tried the git version using composer but still when i go to it redirects me to and there are listed all the invoiceninja files. Can someone help me?


If it works you can try removing /public by uncommenting a line in the .htaccess file.

Thanks. I want to remove the public but there is no line in .htaccess that has the “public” word.

Remove index.php

RewriteEngine on
Redirect /setup
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . index.php [L]

Enable the following if you want to force HTTPS access:

#RewriteCond %{SERVER_PORT} 80
#RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R,L]

Check you’re looking at the .htaccess file in the root of the folder, not the one in public/

Also, you’ll likely need to remove Redirect /setup

I am not sure if i understand it right. I have a virtualhost with the subdomain. There is only one .htaccess at the root and its the one i wrote above. Sorry if i am not understanding.

This is the file you’re looking for:

Thanks. Should i add what it contains to the .htaccess i mentioned above?

No, I don’t think that’s likely to help.

I think i got it right, so after i install the app, the .htaccess will be changed to the one you mentioned? I am not sure where to find the file you posted.

I fixed everything. thank you for your support! :slight_smile: