Install Issues On Web Host Server

I have issues on Arvixe. My website works fine but I cannot get invoice ninja to setup. It has to be something simple. I believe it is the .htaccess file settings.
I have tried http://www.mysitedomain/ninja/setup and http://www.mysitedomain/ninja/public/setup .Both give me error 404 page not found. I can see the files fine if I use http://www.mysitedomain/ninja/
Please help sort this out. Thanks

If you’re seeing a 404 it’s most likely a problem with the web server configuration.

Are there any errors in the web server error logs?

No other error. do we need to move the .htacces file from public dir in ninja folder or leave everything as is and re-route through adding sub-domain.

You shouldn’t need to move any files.

The best practice to remove public/ from the URL is to map the webroot to the folder, alternatively you can uncomment RewriteRule ^(.*)$ public/$1 [L] in the .htaccess file.

well on Arvixe i can not map the webroot as I do not have access to /etc/apache2/sites-available/000-default.conf I did subdomain and pointed it to /public folder but still no go. Any other suggestion would be appreciated or steps how to do this Please help. Thanks

If your server has Softaculous you may want to use our automated installer.

Our app uses the Laravel framework which should work, you may want to follow up with your web host for advice.

Fixed! Here are the steps I did on my web host server, maybe this help others in the same boat.

  1. unzip invoice ninja on your web host webroot dir.
  2. cd into ninja dir that you just unzipped
  3. edit /config/database.php match to your ninja database info
  4. chmod -R 777 storage
  5. cd into public dir and make sure index.php has right permissions if not make it 0644
  6. uncomment RewriteRule ^(.*)$ public/$1 [L] in the .htaccess file
  7. do not edit .htaccess file in public dir
  8. got to your web host Cpanel make new subdomian and enter path ex. public_html/ninja/public
    9 try the subdomain URL like this

If all was done right it should lead you to the install page. Hope this helps
Feel free to ask any questions. Cheers

Thanks for sharing the steps!

  1. This step shouldn’t be required, the values are set on the /setup screen

  2. Rather than set 777 permissions you can run chmod -R 755 storage and sudo chown -R www-data:www-data storage bootstrap public/logo

Update: Step 4 Should be chmod -R 755 storage not 777

But this step: sudo chown -R www-data:www-data storage bootstrap public/logo
gave me an error on my Arvixe web host server but my setup still proceeded fine and I am able to use Invoice Ninja with no issues.

If you still have the specific error we could try to help debug it.

In general it’s best to avoid using 777, although it does work.

Glad to hear it’s working now!

You mean to help sort this step: sudo chown -R www-data:www-data storage bootstrap public/logo
Is it really needed if my setup is working fine.

It’s needed if you want to use 755 permissions in place of 777.

I understand I made an error when adding step 4. I should have written chmod -R 755 storage. I have fixed this on my setup… But this step:
sudo chown -R www-data:www-data storage bootstrap public/logo
sudo: effective uid is not 0, is sudo installed setuid root?

Do i need this step, what does it do exactly

Try running it without sudo

chown -R www-data:www-data storage bootstrap public/logo

It changes the ownership of the files making 755 work in place of 777.

chown -R www-data:www-data storage bootstrap public/logo

gives me error: chown: invalid user: `www-data:www-data’

I assume your web server is running as a different user, then next step would be determining the user name.

Here’s one solution:

I used this command from your link:
ps aux | egrep ‘(apache|httpd)’

output was:
priya 36 0.0 0.0 6308 468 ? RN+ 13:28 0:00 egrep (apache|httpd)

Maybe you’re using Nginx?

From PhPMyadmin Server type: Percona Server

I believe Percona Server is a database, not a web server.