Import Not Bringing Some Data

I’ve tried different ways and still no success.

I have 2 custom fields on the client area. One is a date, and another one is a single line text. They are NOT importing. I even changed the format of the date on the csv to match the formatting on Invoice Ninja but they will not import.

Also another question…
There are regular fields for a client that WILL NOT appear on the mapping. For example I have on my sheet a phone for the store/client and another for phone 2, which is usually the mobile phone of the contact. You can only bring 1 phone and is for the contact. Why is that? How could I bring both phones?


Thanks for reporting these issues!

cc @david


Can you please check in the v5 database in the clients table whether the actual custom_value is appearing being stored?

I am trying to work out if it is being stored, but not displayed or not even being migrated at all.

In regards to the phone, can you advise which fields you are using for phone and phone2 please.

No, the data is not coming at all to the database. It’s nowhere to be found. Also, check this. I entered those 2 custom fields for a customer to see if they actually show up on the database. They do BUT, if you try to use the edit button on the calendar (for a date), this is what happens:

even though if you enter it directly to the field with the proper format, doesn’t give the error.

About the phones, I can ONLY import 1 of the numbers, because there’s only 1 appearing on my mapping, and that’s the CONTACT’S PHONE.

Nothing? Did you do anything about this? test?

@ideasgirl yes, I’ve had a look into this but I haven’t been able to recreate what you are seeing so far.

So all your custom fields come just fine?
All your dates come in fine? (specially if being custom fields)?
You can import the phone for the company? (it won’t come up on mapping for me?)

After 4 months these issues continue. Now, even though I have 2 phones to import, now none of them import.

The custom fields do not import.

The restrictions on the date I figured out that if I change the format and I enter it EXACTLY as in the settings, they will stay on the field.

Can you post a screenshot of the field mapping you’re using?

@david do you have any suggestions?


One problem I see is each field can only be selected once, @david may have other suggestions.

After selecting it looks like it’s the same, but they aren’t. That’s why I posted an image with the selection opened so you can see that they are 2 different fields.

Thanks, understood.

@david any thoughts?


I am tagging v5.3.6 just for you :slight_smile: