How to rename/hide email templates?

When emailing a quote or invoice there are multiple email temapltes: initial, first custom, second custom, first reminder, statement, custom 1, custom2, etc.

That’s confusing and it’s easy to make a mistake - I’m afraid of accidentally using the wrong one and making a fool of myself with the client :slight_smile:

So I tried to hide those I don’t use, but I couldn’t find a way to do that.

So instead I tried to rename them:

  • I went to settings, then localization, then custom labels. I clicked “Add Custom”, and added custom1 (I also tried first_custom). The default is “First Custom”, so I changed it to “Invoice with discount”.
  • I then went to settings, then templates and reminders. I chose the “First Custom” email template, and edited it.
  • Then I created a new invoice, and then clicked “Email Invoice”. It shows “Initial Email”, so I clicked the dropdown to select my other template. But it still shows “First Custom” rather than “Invoice with discount”.

Am I doing this wrong???

How do I rename those dropdowns, if at all possible? And also is it possible to hide templates I don’t use from that dropdown? (if not, would you maybe be willing to consider that a “Feature Request”?)


Thanks for the feedback! We’ll look into hiding the options if the templates are blank.

If you update the translation for ‘first_custom’ it would be applied everywhere the string is shown in the app.

1 Like

That’s what I thought, but it doesn’t work that way, unless I’ve made a mistake.

To eliminate the possibility that it’s my installation, I tried on If you go there you’ll see I added a custom label for first_custom and called it “My Amazing Template”.

But when sending a quote/invoice that dropdown still shows “First Custom”.

Thanks for considering to hide unused templates, that would also help tremendously. I assume fr most users they won’t use all of them anyway.

Just tried the last version.

It still doesn’t show the localized text for first_custom in that dropdown. Still shows “First Custom”.

(By the way, localization acts weird in general. I also I tried changing PO Number to “Reference”, and it shows that in the PDF, but not in the UI in the new quote/invoice forms.)

The change was to only show “First Custom” if the client/group/company has a custom template, only labels in the client portal and PDF are translated.

I was confused by your comment

If you update the translation for ‘first_custom’ it would be applied everywhere the string is shown in the app

So this is by design, I can’t change the names of the templates in that dropdown? So “First Custom” stays “First Custom” even if there’s a translation?

Yes, that is correct

OK. Just one last thing though, how come if I use the french/german/whatever localization it will be different in those dropdowns? Is that a different kind of localization mechanism then?

Correct, they’re separate code paths. The custom localizations are intended to customize the client facing parts of the app, not the admin portal.