How to install localhost MAMP

Again, all I did was download the zip file and extract. I downloaded it again and the quotes ’ were filled ’ so I reinstalled. It still didn’t work.

I then went to github and zipped up the package and installed, still doesn’t work, but I don’t get the error messages I posted in my third post.

I did find something interesting in line one of the following image:

It says “update default key to enable setup page to load”

I too am not able to get to the setup page.

Kind regards,

If you use the code from GitHub you need to run composer install to download third party libraries.

This is the change I’m advising you to make, it will be included with our next release.

I made the changes as you requested in the setup using the zip file from the website as you said “I would need additional files”

Here is what my file currently looks like:

I continue to get the error message.

Kind regards,

While I wait, I figured I would upload the zip file to my live web server. I unzipped it server side and moved all the files into the root of my domain.

I then navigated to:

Http:// and I get the following error:

[an error occurred while processing this directive]

Any thoughts on why I am unable to get a configuration screen on either environments?

Thank you,

You need to have just one line in app.php.

‘key’ => env(‘APP_KEY’, ‘SomeRandomStringSomeRandomString’),

Hi Hillel, I did that, as shown in my very last image in reply #3670

However I went ahead and did it again, for completeness and it continues to not work.

Thank you for your suggestions.

Kind regards,

In your reply #3676 you mentioned: “You could try use SomeRandomString with rijndael-128 as the cipher”

I have created a new image, you can see for yourself that line 85 chase been changed as per your recommendation.

Please note line 87 where it references “AES 256” – could that be part of the problem?

Kind regards,

I think the problem is the quotes you’re using, you can see the text is different colors in the screenshot.

The colour has nothing to do with it. I copied and pasted it from your source. If you look at my entire screen capture, all the files are purple. If I opened it in dream-weaver the colours would most certainly be different. If I opened it in Coda, I’m sure they would be different once again. There would be nothing wrong with me opening this file in notepad. All the text would be in black and white, which doesn’t make the code wrong.

So, no, the quotes are a direct copy and paste from the github link you sent me.

Again, I would like to note, that I uploaded the zip file to my hosting company and it doesn’t work there either. See my above post for the details. Clearly the configuration page isn’t loading… I have tried it on bluest and localhost.

Kind regards,

Please compare the single quotes on lines 85 and 87, they’re different. That’s the reason your code editor is showing the texts as different colors.

For completeness, I have copied quotes for another line, re-uploaded the zip file and used the original quotes. I have tried every possible scenario to put your fear of bad single quotes to rest. Understanding a thing or two about unicode, I feel comfortable telling you all the colours are the same and the quotes are the exact same ones you sent, were used and reside on the repository.

The configuration still doesn’t work. Did I mention that I tried uploading this to my live web hosting account and still no setup screen.


We’ve just released a new version, maybe it will help:

Ok, I will try it in the next few hours and report.

Thank you,

I got held up with some matters.

I tried the latest version of the software and the configuration screen finally came up. I had been trying I believe since version 2.5.5 and this is the first time it worked in local host.

Thank you for updating invoice ninja… version 2.6.8 finally worked for me. I can now get down to really trying out this software.

I had tried bitnami’s software and when I went back to it earlier this week I noticed that is no longer supported. What happened to the bitnami build?

Thank you.

Great news!

We couldn’t afford the fees to remain on their platform :frowning:

Yes, thank you kindly for all your help in the matter. All I did was unzip the file and it worked.

I will be showing this software to a client of mine on Monday afternoon. They are looking for a SAAS to do their invoicing. They would like to have it localhost to start, as they are a little concerned with the security aspect of putting contact information into the cloud.

They already have been made aware that there is a white label charge to send invoices and to support the project. I do have two questions that came up right away.

  1. Email with google business apps needs to be set to “less secure” so that emails will send out.
  2. HTML emails could use a little more customization. When I sent a test quote to myself to see how the email looks it is not super ideal when the wording in the header part of the HTML message says “due by” – It is my humble opinion that this would better read “expires”

I will open two separate threads for the above two questions if necessary after searching through the forum for answers.

Thank you again, Hillel, for your assistance. Please consider this topic closed.

Kind regards,