How to add new currency

Hello everyone!

Working on Self-hosting v4.5.13

i’m new around here. I just donwloaded and installed the latest self-hosting ninja and I just saw that the currency I need is not listed in there. So how/where do I add it?

Thanks for any answer.

You can add it here and then load /update, you’d also need to add the text localization strings.

If you provide the details we’re also happy to add it to the app.

I’ll do that then come back here with the details! Thanks for the answer.

Hi Hillel! I added the new currency in the CurrencysSeeder. I looked at the currency info here: It’s the Malagasy Ariary, code and Symbol = MGA.

But where do I add the text localization strings. Is it in resources/lang?


That’s what I’ve done but nothing appears in the dropdown. Gonna check if i haven’t mispelled something.

Ok, now I’m a bit lost. I’ve added the currency in the seeder

['name' => 'Gibraltar Pound', 'code' => '', 'symbol' => 'GIP', 'precision' => '2', 'thousand_separator' => ',', 'decimal_separator' => '.'],
['name' => 'Malagasy Ariary', 'code' => 'MGA', 'symbol' => 'Ariary', 'precision' => '0', 'thousand_separator' => '.', 'decimal_separator' => ','],

and the text localization string

'currency_gibraltar_pound' => 'Gibraltar Pound',
'currency_malagasy_ariary' => 'Malagasy Ariary',

but still nothing appears. What have I done wrong?

Have you added the strings in the language file you’re using in the app?

Yes! Using the french version and added it to the texts.php file in fr as well as the en folder but still nothing. Any hint?

Sorry, not sure…


Since my install was vanilla I decided to:

  1. erase everything (from ftp to database)
  2. added the new currency in seeds currencies and in sql setup file
  3. updated both en and fr text language strings
  4. uploaded everything
  5. relaunched a brand new installation

And taddaaa!!! I got my app up and running with my new currency!

Thanks for the time you used to help me out. Keep up the great work :slight_smile:

Glad to hear it, thanks for the update!

Hi, I’m having the same issue, can you show me where did you add the currency in the setup.sql file.
update i added the currency in 3 places. en folder/texts.php , seeds/CurrenciesSeeder.php
then restarted nginx and mysql and also restarted the server and still the currency did not showed up.
Currency Code SDG
Display Name Sudanese Pound

I suggest updating the currencies table in the database and then clearing the cache by adding ?clear_cache=true to the URL.

thanks for the replay. So I only need to add it in the currencies table?
What about the texts.php and seeds/CurrenciesSeeder.php?

texts.php is need to update the UI. If you update the database directly you don’t need to change the seeder file.

ok thanks, it worked from the currencies table but not from the php files.

hi i’m using invoice ninja on interserver - softaculous, i get error 500 when i change text localisation string

Are you changing the code? Are there details about the error in storage/logs/

hi i installed multiple times and still cannot get currency to show in settings/localization

currency is Vanuatu Vatu