How do you set the rate to zero?

I’m trying to set the rate for a task to zero. Every time I set it to zero, it gets set back to the default for the client. I’m guessing the “if” check does something like “if $rate” instead of checking if $rate is non-empty. Is there a way to set a task rate to zero?

Thanks!

Hi,

I don’t believe this is currently supported.

@david any thoughts?

Have you tried something like 0.00001 ? It might get rounded to 0.00 but is not exactly 0 so would not automatically get set to the default.

I haven’t tried this but maybe it works.

1 Like

Thanks, that’s a good suggestion!

@hillel

Looks like the task rate is set via the front end when the invoice is generated. I can see the API accepts the $0 task rate.

I think they’re referring to the default task rate for the client setting, I believe 0 is treated as a blank value.

@hillel

Yes, that looks correct, 0 means we use the client / company defaults

Is there a way to set the task rate to zero, and override a client’s default rate?

@jkugler

Did ecomsilio’s solution of using a small value like 0.0001 work?

Just tried it. It did work, thanks!

1 Like

Hmm…but then the rate of .00001 shows up in the invoice.

You can edit it…but it would still be nice if you could specify 0.00 in the task rate.

In my experience it’s good to let a client know how much you’re doing for them for free. Perhaps setup a 100% discount? Just a thought.